php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76969 Update timezone to 2018 for Brazil
Submitted: 2018-10-04 11:35 UTC Modified: 2018-10-04 11:59 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: emiliopedrollo at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: timezonedb (PECL)
PHP Version: Irrelevant OS: Any
Private report: No CVE-ID: None
 [2018-10-04 11:35 UTC] emiliopedrollo at gmail dot com
Description:
------------
Due to presidential decreet, the DST dates had changed.

The new date for the start of the daylight savings is now November 18th at 00:00 am  instead of November 4th only for 2018.

This should apply for every time zone that uses DST on Brazil.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-10-04 11:59 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2018-10-04 11:59 UTC] cmb@php.net
PHP's timezonedb is build from the Time Zone Database maintained
by iana[1].  The latest release is 2018e, which corresponds to
timezonedb 2018.5. So please report this issue to iana (if that
did not already happen).

[1] <https://www.iana.org/time-zones>
 [2018-10-04 17:53 UTC] emiliopedrollo at gmail dot com
It was already discussed[1] and updated in the development version[2]. It's planned for a new release for after the presidential decree be officially released. 


[1] <https://mm.icann.org/pipermail/tz/2018-October/026921.html>
[2] <https://github.com/eggert/tz>
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat May 25 03:01:26 2019 UTC