php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #76953 gcc warning
Submitted: 2018-09-30 17:46 UTC Modified: 2018-10-27 16:28 UTC
From: office at vargapeter dot net Assigned:
Status: Duplicate Package: Apache2 related
PHP Version: 7.2.11 OS: Any
Private report: No CVE-ID: None
 [2018-09-30 17:46 UTC] office at vargapeter dot net
Description:
------------
/builds/php-7.2.10/sapi/apache2handler/sapi_apache2.c: In function ‘php_ap2_register_hook’:
/builds/php-7.2.10/sapi/apache2handler/sapi_apache2.c:745:21: warning: passing argument 1 of ‘ap_hook_child_init’ from incompatible pointer type [-Wincompatible-pointer-types]
  ap_hook_child_init(zend_signal_init, NULL, NULL, APR_HOOK_MIDDLE);
                     ^~~~~~~~~~~~~~~~
In file included from /usr/include/apache2-prefork/ap_hooks.h:40,
                 from /usr/include/apache2-prefork/ap_config.h:25,
                 from /builds/php-7.2.10/sapi/apache2handler/sapi_apache2.c:37:
/usr/include/apr-1/apr_hooks.h:120:61: note: expected ‘void (*)(apr_pool_t *, server_rec *)’ {aka ‘void (*)(struct apr_pool_t *, struct server_rec *)’} but argument is of type ‘void (*)(void)’
 link##_DECLARE(void) ns##_hook_##name(ns##_HOOK_##name##_t *pf, \
/usr/include/apache2-prefork/ap_hooks.h:75:9: note: in expansion of macro ‘APR_DECLARE_EXTERNAL_HOOK’
         APR_DECLARE_EXTERNAL_HOOK(ap,AP,ret,name,args)
         ^~~~~~~~~~~~~~~~~~~~~~~~~
/usr/include/apache2-prefork/http_config.h:1295:1: note: in expansion of macro ‘AP_DECLARE_HOOK’
 AP_DECLARE_HOOK(void,child_init,(apr_pool_t *pchild, server_rec *s))

Expected result:
----------------
No warning


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-09-30 17:49 UTC] spam2 at rhsoft dot net
exists for years, i reported that long ago, nobody cares
 [2018-09-30 17:51 UTC] nikic@php.net
-Status: Open +Status: Duplicate
 [2018-09-30 17:51 UTC] nikic@php.net
@rhsoft: Indeed, this is a duplicate of bug #75479.
 [2018-10-27 16:17 UTC] office at vargapeter dot net
-PHP Version: 7.2.10 +PHP Version: 7.2.11
 [2018-10-27 16:17 UTC] office at vargapeter dot net
This fix does NOT exist in 7.2.11 - is there a reason that it hasn't been rolled out?
 [2018-10-27 16:28 UTC] nikic@php.net
This fix will be in 7.2.12, scheduled for Nov 8th. The commit landed shortly after the RC cutoff for 7.2.11.
 [2018-10-27 16:30 UTC] spam2 at rhsoft dot net
the tarballs from here are your friend:
https://git.php.net/?p=php-src.git;a=shortlog;h=refs/heads/PHP-7.2

besides production i don't care about stable, RC, Beta or whatever and so for my daily work machines mostly once in a week the latest 7.2-HEAD is built as RPM package and due switching to 7.3 it will be the same with https://git.php.net/?p=php-src.git;a=shortlog;h=refs/heads/PHP-7.3
 [2018-10-28 01:04 UTC] takagi@php.net
Automatic comment from SVN on behalf of takagi
Revision: http://svn.php.net/viewvc/?view=revision&revision=345918
Log: Update translation

patch by anonymous #76951 and anonymous #76953
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jun 25 18:01:26 2019 UTC