php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76756 Will not configure or compile on ubuntu 18.04 due to libcurl4
Submitted: 2018-08-16 23:49 UTC Modified: 2019-04-01 09:04 UTC
From: scott dot yeadon at anu dot edu dot au Assigned: omars (profile)
Status: Not a bug Package: solr (PECL)
PHP Version: Irrelevant OS: Ubuntu 18.04
Private report: No CVE-ID: None
 [2018-08-16 23:49 UTC] scott dot yeadon at anu dot edu dot au
Description:
------------
phpize -v
Configuring for:
PHP Api Version:         20151012
Zend Module Api No:      20151012
Zend Extension Api No:   320151012

./configure
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php/20151012 -I/usr/include/php/20151012/main -I/usr/include/php/20151012/TSRM -I/usr/include/php/20151012/Zend -I/usr/include/php/20151012/ext -I/usr/include/php/20151012/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
checking for PHP extension directory... /usr/lib/php/20151012
checking for PHP installed headers prefix... /usr/include/php/20151012
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
checking for gawk... gawk
checking for cURL support... yes, shared
checking for cURL in default path... not found
configure: error: Please reinstall the libcurl distribution -
	easy.h should be in <curl-dir>/include/curl/


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-08-17 01:39 UTC] scott dot yeadon at anu dot edu dot au
Updated php-config to 7.2 as 18.04 uses php 7.2, also had to reinstall php-curl:
phpize
Configuring for:
PHP Api Version:         20170718
Zend Module Api No:      20170718
Zend Extension Api No:   320170718
autoconf: warning: both `configure.ac' and `configure.in' are present.
autoconf: warning: proceeding with `configure.ac'.
autoheader: 'configure.ac' and 'configure.in' both present.
autoheader: proceeding with 'configure.ac'


but during make I get a whole series of Zend based errors like the onle following:
In file included php.h:40:0,
                 php_solr.h:28,
                 php_solr.c:23:
src/php7/php_solr.c:560:56: error: ‘ZEND_ACC_CLONE’ undeclared here (not in a function); did you mean ‘ZEND_AST_CLONE’?
  PHP_ME(SolrDocument, __clone, NULL, ZEND_ACC_PUBLIC | ZEND_ACC_CLONE)
                                                        ^
20170718/Zend/zend_API.h:70:157: note: in definition of macro ‘ZEND_FENTRY’
 #define ZEND_FENTRY(zend_name, name, arg_info, flags) { #zend_name, name, arg_info, (uint32_t) (sizeof(arg_info)/sizeof(struct _zend_internal_arg_info)-1), flags },
 [2018-08-17 05:04 UTC] scott dot yeadon at anu dot edu dot au
built from Git clone seems to have resolved the problem, maybe another release is needed as 2.4.0 will not work.
 [2019-03-29 09:34 UTC] omars@php.net
-Assigned To: +Assigned To: omars
 [2019-03-29 09:34 UTC] omars@php.net
yea, that's already fixed on master, new release coming stay tuned ;)
 [2019-04-01 09:03 UTC] omars@php.net
the curl 4 compatibility has to do with php itself, you can install it on /opt/ for instance and use 
./configure --with-curl=/opt/curl
 [2019-04-01 09:04 UTC] omars@php.net
-Status: Assigned +Status: Not a bug
 [2019-04-01 09:04 UTC] omars@php.net
libcurl4 is not supported by php, nothing to do with the extension
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Jul 24 06:01:27 2019 UTC