php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #76642 Deflate64 is not supported
Submitted: 2018-07-19 02:42 UTC Modified: 2018-07-21 13:01 UTC
From: concept92 at live dot com Assigned: cmb (profile)
Status: Wont fix Package: zip (PECL)
PHP Version: 5.6.36 OS: debian
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2018-07-19 02:42 UTC] concept92 at live dot com
Description:
------------
Please add support for deflate64  (unzip at the very least).
Right now php zip fails to unpack files that use that compression method.

Sample file : http://upload.tjbp.net/zipbug.zip

Test script:
---------------
$za = new \ZipArchive;

$za->open('zipbug.zip');

var_dump($za->getStream('gta_sa.set'));


Expected result:
----------------
Contents of the file in the archive

Actual result:
--------------
NULL

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-07-19 05:49 UTC] a at b dot c dot de
It's something to do with the introduction of DateTimeImmutable and their common interface in 5.5.0 (the same version information is given for the other methods declared by that interface). I agree the notation is confusing, and the mechanism for determining that information might benefit from a look-see.
 [2018-07-21 13:01 UTC] cmb@php.net
-Status: Open +Status: Wont fix -Assigned To: +Assigned To: cmb
 [2018-07-21 13:01 UTC] cmb@php.net
Actually, this is an upstream issue.  libzip does not support
Deflate64, because zlib does not support it.  Since the zlib FAQ
states that ?it's not worth the effort to implement?[1] it, it's
unlikely to ever be implemented.

[1] <https://zlib.net/zlib_faq.html#faq40>
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat May 25 01:01:26 2019 UTC