php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76299 Your internal websites links without www not working
Submitted: 2018-05-03 13:46 UTC Modified: 2019-05-21 01:45 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: iran dot info dot technology at gmail dot com Assigned: petk (profile)
Status: Closed Package: Website problem
PHP Version: Irrelevant OS: windows 7
Private report: No CVE-ID: None
 [2018-05-03 13:46 UTC] iran dot info dot technology at gmail dot com
Description:
------------
when surfing your website most internal link is without www and page not opened and say This site can’t be reached. but if i add www to begining of that url, then page open correctly.
for example:
Not work:
http://php.net/array_intersect

Work:
http://www.php.net/array_intersect


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-05-03 13:49 UTC] kalle@php.net
-Status: Open +Status: Feedback
 [2018-05-03 13:49 UTC] kalle@php.net
Try go to:

http://www.php.net/my.php and set a mirror, as the mirror you could currently be using could be encountering an error.

If you can figure out which one you are using (based on your username I would assume iran, which have had known issues in the past) then I can add a note in our mirror administration
 [2018-05-03 20:47 UTC] iran dot info dot technology at gmail dot com
-Status: Feedback +Status: Open
 [2018-05-03 20:47 UTC] iran dot info dot technology at gmail dot com
When i set a mirror and then click Set All Preferences button then page will send data to http://php.net/my.php page and again This site can’t be reached. i checked   form action is : action="/my.php" but i dont know why change subdomain www to none www.
But i think its very bad proccess because site must have default mirror or work with two form www or non-www because new customers don't know must set mirror before using this site.
 [2018-05-24 21:09 UTC] nabikaz at gmail dot com
I have this problem too. but just from iran country.
I think that for those who have opened this issue, it's just for Iran.

For me, The main site (php.net) don't open.
But all mirror works well. so the available mirror of iran (ir2.php.net) don't have any problem and works well.
In summary, I just have problem with opening "php.net" domain from IP of iran country.
 [2018-07-23 02:27 UTC] carusogabriel@php.net
-PHP Version: Next Major Version +PHP Version: Irrelevant
 [2019-05-21 01:45 UTC] petk@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: petk
 [2019-05-21 01:45 UTC] petk@php.net
This should now work more or less except that we are still waiting for this ticket to be resolved first: https://bugs.php.net/bug.php?id=78037

The PHP site is now not using mirrors anymore and there is only one canonical link for that matter. So expect the most proper solution when the redirection is done.

Thank you for reporting issues. I'll close this one in favor of the redirection issue for now.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Aug 21 02:01:27 2019 UTC