php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76168 icu 61.1 causes php-intl 7.1.16 to fail to build
Submitted: 2018-03-30 17:18 UTC Modified: 2018-03-30 17:28 UTC
From: ai5hf at hotmail dot com Assigned: cmb (profile)
Status: Duplicate Package: Compile Failure
PHP Version: 7.1.16 OS: Arch Linux
Private report: No CVE-ID: None
 [2018-03-30 17:18 UTC] ai5hf at hotmail dot com
Description:
------------
I get the following errors (along with related errors) when compiling php 7.1.16 -- the intl extension. Looks like icu 61.1 may have changed something such that the include no longer works.

In file included from /home/lilmike/.cache/pacaur/php71-noconflict/src/php-7.1.16/ext/intl/intl_convertcpp.cpp:21:0:
/home/lilmike/.cache/pacaur/php71-noconflict/src/php-7.1.16/ext/intl/intl_convertcpp.h:29:25: error: UnicodeString was not declared in this scope
int intl_stringFromChar(UnicodeString &ret, char *str, size_t str_len, UErrorCode *status);
^~~~~~~~~~~~~
/home/lilmike/.cache/pacaur/php71-noconflict/src/php-7.1.16/ext/intl/intl_convertcpp.h:29:25: note: suggested alternative:
In file included from /home/lilmike/.cache/pacaur/php71-noconflict/src/php-7.1.16/ext/intl/intl_convertcpp.h:26:0,
from /home/lilmike/.cache/pacaur/php71-noconflict/src/php-7.1.16/ext/intl/intl_convertcpp.cpp:21:
/usr/include/unicode/unistr.h:286:20: note:   icu_61::UnicodeString
class U_COMMON_API UnicodeString : public Replaceable


-Michael.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-03-30 17:28 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2018-03-30 17:28 UTC] cmb@php.net
This looks like a duplicate of bug #76153.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Jul 21 08:01:25 2019 UTC