php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75381 PECL package doesn't provide lzf.h
Submitted: 2017-10-15 12:00 UTC Modified: 2018-03-05 13:18 UTC
From: p dot yatsukhnenko at gmail dot com Assigned:
Status: Not a bug Package: lzf (PECL)
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: p dot yatsukhnenko at gmail dot com
New email:
PHP Version: OS:

 

 [2017-10-15 12:00 UTC] p dot yatsukhnenko at gmail dot com
Description:
------------
Hi.
I'm going to add lzf compression to phpredis extension but I can't add this package as dependency because it doesn't provide lzf.h file after installing.
Here are related issue https://github.com/phpredis/phpredis/issues/1048 and pull request
https://github.com/phpredis/phpredis/pull/1253
for phpredis extension.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-03-05 13:18 UTC] remi@php.net
-Status: Open +Status: Not a bug
 [2018-03-05 13:18 UTC] remi@php.net
No public API from this extension.

You probably need to link against liblzf.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Jun 10 11:03:38 2023 UTC