php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #75032 Typo NumberFormatter SpellOut for id-ID
Submitted: 2017-08-04 03:06 UTC Modified: 2017-08-04 07:46 UTC
Votes:1
Avg. Score:2.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: gniko dot wicaksono at gmail dot com Assigned:
Status: Not a bug Package: intl (PECL)
PHP Version: 7.1.8 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gniko dot wicaksono at gmail dot com
New email:
PHP Version: OS:

 

 [2017-08-04 03:06 UTC] gniko dot wicaksono at gmail dot com
Description:
------------
As stated above, it's wrongly spell out juta instead of juts

Test script:
---------------
$n = new NumberFormatter('id-ID', NumberFormatter::SPELLOUT);
echo $n->format('1000000');

Expected result:
----------------
satu juta

Actual result:
--------------
satu juts

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-08-04 05:57 UTC] requinix@php.net
-Status: Open +Status: Feedback -Package: *General Issues +Package: intl
 [2017-08-04 05:57 UTC] requinix@php.net
I'm finding many sources that say it should be "juta", and that "juts" is not a word.

Or are you saying you get "juts"? What version of libicu did you build against?
 [2017-08-04 07:09 UTC] gniko dot wicaksono at gmail dot com
Yes I'm getting juts instead of juta.

root@2355fda708e6:/var/www/html# apt show libicu52
Package: libicu52
Status: install ok installed
Priority: optional
Section: libs
Installed-Size: 28.0 MB
Maintainer: Laszlo Boszormenyi (GCS) <gcs@debian.org>
Source: icu
Version: 52.1-8+deb8u5
Depends: libc6 (>= 2.14), libgcc1 (>= 1:4.1.1), libstdc++6 (>= 4.9)
Pre-Depends: multiarch-support
Homepage: http://www.icu-project.org
Download-Size: unknown
APT-Manual-Installed: no
APT-Sources: /var/lib/dpkg/status
Description: International Components for Unicode
 ICU is a C++ and C library that provides robust and full-featured
 Unicode and locale support.  This package contains the runtime
 libraries for ICU.
 [2017-08-04 07:46 UTC] requinix@php.net
-Status: Feedback +Status: Not a bug
 [2017-08-04 07:46 UTC] requinix@php.net
An old bug identified in the Unicode CLDR project.
http://unicode.org/cldr/trac/ticket/6994

It was fixed with CLDR 26. You need to upgrade to libicu >= 54.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Feb 25 00:01:26 2020 UTC