php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7489 Place holder bug
Submitted: 2000-10-27 05:10 UTC Modified: 2000-10-27 22:30 UTC
From: artur at lunar dot com dot pl Assigned:
Status: Closed Package: InterBase related
PHP Version: 4.0.3pl1 OS: RH Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
3 + 11 = ?
Subscribe to this entry?

 
 [2000-10-27 05:10 UTC] artur at lunar dot com dot pl
I think there is a bug PHP 4.0.3 in interbase support.
The place holders '?' don't seem to work correcty.
The following example works with PHP 3.0.15

$set = ibase_query("SELECT FOTO FROM TEST WHERE ID = ?",$id);

The same example does not work with PHP 4.0.3 and PHP 4.0.3pl1

if I do the following it works OK

$set = ibase_query("SELECT FOTO FROM TEST WHERE ID = 1");

Please help.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-10-27 16:28 UTC] mathieu@php.net
Please update to CVS and see if problem persists.

 [2000-10-27 22:30 UTC] jah@php.net
Fixed in current CVS. Fetch a new version of ext/interbase/interbase.c from
http://cvs.php.net/viewcvs.cgi/~checkout~/php4/ext/interbase/interbase.c?rev=1.45
and recompile.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 01 02:05:54 2022 UTC