php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #74809 Calling session_cache_expire() to retrieve the value triggers a warning
Submitted: 2017-06-23 22:59 UTC Modified: 2017-06-23 23:59 UTC
From: smorozov at sugarcrm dot com Assigned:
Status: Duplicate Package: Session related
PHP Version: 7.2.0alpha2 OS: Linux
Private report: No CVE-ID: None
 [2017-06-23 22:59 UTC] smorozov at sugarcrm dot com
Description:
------------
If called after session_start(), even without the $new_cache_expire argument passed, session_cache_expire() triggers a warning on PHP 7.2 alpha2. The same works fine on PHP 7.1.6 and earlier versions.

Test script:
---------------
<?php

session_start();
session_cache_expire();


Expected result:
----------------
No warning triggered

Actual result:
--------------
Warning: session_cache_expire(): Cannot change cache expire when session is active in test.php on line 4


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-06-23 23:59 UTC] requinix@php.net
-Status: Open +Status: Duplicate
 [2017-06-23 23:59 UTC] requinix@php.net
Duplicate of bug #74514.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri May 24 16:01:26 2019 UTC