php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #73848 Make PHP Cross Compilable
Submitted: 2017-01-01 15:41 UTC Modified: 2017-01-11 05:12 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: subins2000 at gmail dot com Assigned:
Status: Not a bug Package: *Compile Issues
PHP Version: 7.1.0 OS: Ubuntu 16.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: subins2000 at gmail dot com
New email:
PHP Version: OS:

 

 [2017-01-01 15:41 UTC] subins2000 at gmail dot com
Description:
------------
Currently while trying to cross compile PHP, this error is outputted by configure script : 

cannot run test program while cross compiling

It is time PHP needed to be made cross compilable.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-01-11 05:12 UTC] krakjoe@php.net
-Status: Open +Status: Not a bug
 [2017-01-11 05:12 UTC] krakjoe@php.net
I'm going to close this as not a bug.

Cross compiling autotools configured software very often requires that you set ac vars for configure.

Setting the correct ac vars will allow you to avoid executing tests that usually determine the value for those vars.

This is not a limitation of PHP, but of autotools.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Mar 30 14:01:24 2020 UTC