php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #73728 out of memory while doing session_start(session handler memcache)
Submitted: 2016-12-13 06:03 UTC Modified: 2017-01-11 06:00 UTC
Votes:6
Avg. Score:4.7 ± 0.7
Reproduced:6 of 6 (100.0%)
Same Version:3 (50.0%)
Same OS:2 (33.3%)
From: mahesh dot patade at network18tech dot com Assigned:
Status: Duplicate Package: Session related
PHP Version: 7.0.14 OS: CentOS 6.5
Private report: No CVE-ID: None
 [2016-12-13 06:03 UTC] mahesh dot patade at network18tech dot com
Description:
------------
PHP Version details:

php-7.0.14-1.el6.remi.x86_64
php-cli-7.0.14-1.el6.remi.x86_64
php-common-7.0.14-1.el6.remi.x86_64
php-devel-7.0.14-1.el6.remi.x86_64
php-gd-7.0.14-1.el6.remi.x86_64
php-imap-7.0.14-1.el6.remi.x86_64
php-json-7.0.14-1.el6.remi.x86_64
php-mbstring-7.0.14-1.el6.remi.x86_64
php-mcrypt-7.0.14-1.el6.remi.x86_64
php-mysqlnd-7.0.14-1.el6.remi.x86_64
php-odbc-7.0.14-1.el6.remi.x86_64
php-pdo-7.0.14-1.el6.remi.x86_64
php-pear-1.10.1-8.el6.remi.noarch
php-pear-Auth-SASL-1.0.6-1.el6.remi.noarch
php-pear-Mail-1.3.0-1.el6.remi.noarch
php-pear-Net-SMTP-1.7.2-1.el6.remi.noarch
php-pear-Net-Socket-1.0.14-1.el6.remi.noarch
php-pecl-apcu-5.1.7-1.el6.remi.7.0.x86_64
php-pecl-apcu-bc-1.0.3-1.el6.remi.7.0.x86_64
php-pecl-igbinary-2.0.0-1.el6.remi.7.0.x86_64
php-pecl-mailparse-3.0.2-1.el6.remi.7.0.x86_64
php-pecl-memcache-3.0.9-0.7.20161124gitdf7735e.el6.remi.7.0.x86_64
php-pecl-msgpack-2.0.2-1.el6.remi.7.0.x86_64
php-pecl-redis-3.0.0-1.el6.remi.7.0.x86_64
php-pecl-zip-1.13.5-1.el6.remi.7.0.x86_64
php-process-7.0.14-1.el6.remi.x86_64
php-soap-7.0.14-1.el6.remi.x86_64
php-xml-7.0.14-1.el6.remi.x86_64
php-xmlrpc-7.0.14-1.el6.remi.x86_64

List of modules:
apc
apcu
bz2
calendar
Core
ctype
curl
date
dom
exif
fileinfo
filter
ftp
gd
gettext
hash
iconv
igbinary
imap
json
libxml
mailparse
mbstring
mcrypt
memcache
msgpack
mysqli
mysqlnd
odbc
openssl
pcntl
pcre
PDO
pdo_mysql
PDO_ODBC
pdo_sqlite
Phar
posix
readline
redis
Reflection
session
shmop
SimpleXML
soap
sockets
SPL
sqlite3
standard
sysvmsg
sysvsem
sysvshm
tokenizer
wddx
xml
xmlreader
xmlrpc
xmlwriter
xsl
zip
zlib

PHP.INI
session.save_handler = memcache
session.save_path = "tcp://172.29.31.11:11211,tcp://172.29.31.15:11211,tcp://172.29.31.16:11211,tcp://172.29.31.17:11211,tcp://172.29.31.18:11211,tcp://172.29.31.19:11211,tcp://172.29.31.20:11211,tcp://172.29.31.111:11211,tcp://172.29.31.112:11211,tcp://172.29.31.113:11211,tcp://172.29.31.114:11211,tcp://172.29.31.115:11211,tcp://172.29.31.116:11211,tcp://172.29.31.117:11211,tcp://172.29.31.118:11211,tcp://172.29.31.119:11211,tcp://172.29.31.120:11211,tcp://172.29.31.121:11211"




Test script:
---------------
While setting simple session we are getting 500 with below error.
<?php session_start(); ?>


PHP Fatal error:  Out of memory (allocated 2097152) (tried to allocate 18446744073709551612 bytes) in




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-01-03 10:53 UTC] kai dot karki at fiare dot com
The same bug happens with Redis session handler with multiple Redis instances.

Pecl/Redis is the latest available, currently 3.1.0.
 [2017-01-11 06:00 UTC] krakjoe@php.net
-Status: Open +Status: Duplicate
 [2017-01-11 06:00 UTC] krakjoe@php.net
Duplicate of #73728
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri May 24 06:01:27 2019 UTC