php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70765 Windows DLL broken
Submitted: 2015-10-22 04:14 UTC Modified: 2015-11-10 01:34 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: caleb dot ong at hotmail dot com Assigned:
Status: Not a bug Package: solr (PECL)
PHP Version: 5.6.14 OS: Windows 10 x64 PRO
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: caleb dot ong at hotmail dot com
New email:
PHP Version: OS:

 

 [2015-10-22 04:14 UTC] caleb dot ong at hotmail dot com
Description:
------------
The 2.2.1 TS DLL file does not work with PHP 5.6.14 TS, or 5.5.12 TS on 64bit system.

The 2.1.0 TS DLL however works fine with both versions above on the same system... leading me to believe there is something wrong with the build for 2.2.1 on Windows systems.





Test script:
---------------
Try 2.2.1 TS DLL on 5.6.14 TS PHP. PHPINFO() will not load SOLR.
Try 2.1.0 TS DLL on 5.6.14 TS PHP. PHPINFO() will load SOLR.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-10-31 17:53 UTC] kalle@php.net
-Status: Open +Status: Feedback
 [2015-10-31 17:53 UTC] kalle@php.net
Can you please post any errors from your logs that can hint why it failed loading,  if not then it will be next to impossible to debug, thanks
 [2015-11-01 21:55 UTC] caleb dot ong at hotmail dot com
-Status: Feedback +Status: Open
 [2015-11-01 21:55 UTC] caleb dot ong at hotmail dot com
Tested some more... it seems it loads on command line, but not when loaded with Apache server.

Running php -i from command line returns:

Solr Support => enabled
Version => 2.2.1
Last Build Date => Sep 27 2015
Last Build Time => 19:40:48

However, Solr entry is missing in Apache servers phpinfo();

Apache PHP error log is quite generic (despite file existing in location).
[01-Nov-2015 21:41:20 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.6.14/ext/php_solr.dll' - The specified module could not be found. in Unknown on line 0

Tried a non-wamp install of Apache/PHP; same problem.
 [2015-11-06 14:55 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2015-11-06 14:55 UTC] ab@php.net
Thanks for the report. ext/solr has several dependencies, all of them should be contained in the PHP root dir. Please ensure it's on the %path% before starting Apache. When in doubt, you can always check which DLLs are loaded/required with the Process Monitor tool from sysinternals.com.

Thanks.
 [2015-11-10 01:34 UTC] caleb dot ong at hotmail dot com
Indeed, once adding PHP folder to windows PATH; works as expected.
Seems like this is required since version 2.2.

Thanks!
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Dec 04 08:01:23 2020 UTC