php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70407 php_cli program
Submitted: 2015-09-02 11:28 UTC Modified: 2015-09-03 10:02 UTC
From: admin at angosso dot net Assigned: cmb (profile)
Status: Not a bug Package: Built-in web server
PHP Version: 5.6.12 OS: Linux; Windows; Mac
Private report: No CVE-ID: None
 [2015-09-02 11:28 UTC] admin at angosso dot net
Description:
------------
 User and function of the php_cli program with EasyApache 4+ machines.
php_cli program is a drop-in replacement for a PHP binary used on EasyApache 4+ machines that allows for a command line program to run with the correct version of PHP configured for its environment. The php_cli program sits in the /angosson/bin directory as the /angosson/bin/php file.

Test script:
---------------
php_cli.yaml file:
ea_php_yaml: /etc/apache2/conf.d/php.conf.yaml
testing_root_dir: /root/php_cli/test
php_bin_pattern: /opt/cpanel/ea-php%s/root/angosson/bin/php;
dryrun: 0
ea-php54: suphp
ea-php55: suphp
ea-php56: suphp
phpversion: ea-php56;
php /home/angosson/public_html/domain/app/angosson_angosso.php;
testing_root_dir parameter in the php_cli.yaml configuration file.   The system will not ascend past the testing_root_dir parameter in search of a .htaccess file.

Expected result:
----------------
Determine which PHP version and deploy scripts, the php_cli program checks the AddHandler application/x-httpd-php54.php file, located in the .htaccess file.
PHP_INI_SCAN_DIR is set, then 
php -i 
outputs the path and any ini files.
If you enter
php --ini
the ini files are correct, but the scan directory is not.
php --ini is only showing th ...


Patches

angosson (last revision 2015-09-02 11:29 UTC by admin at angosso dot net)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-09-02 13:13 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2015-09-02 13:13 UTC] cmb@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Consider to consult some EasyApache support forum.
 [2015-09-03 10:02 UTC] admin at angosso dot net
I would like a intereaction environment between host and files.
For taking into account the global scripts. Automatic correction of errors according to the Php version used.
Version 5.6 of my environment contains "hostprotect". I would like to specify the option --enable-force-php-live; --enable-force-cgi-redirect; --enable-force-pl-redirect to the configure php-cli program.
The ability to perform the following directives in the server configuration,
 without going through Apache.
* Action php-script / bin / php
* AddHandler php-script .php
 But direct control by php
#! / path / to / interpreter; php_cli program
It will do this at the program php_cli
Checking whether to enable detailed error reporting ... yes
Checking out whether to optimize the DTD (performance gain force) done ...
Generating /my.host/src/domains/doc-base/install/.xml ... done
Generating /my.host/src/domains/doc-base/install-unix.xml ... done
Generating /my.host/src/domains/doc-base/install-angosson.xml ... done
Generating /my.host/src/domains/doc-base/developer.template.xml ... done
Generating /my.host/src/phpdoc-all/doc-base/scripts/file-entities.php ... done
Iterating over extension specific release files ... OK
Saving it ... OK
Creating file ... done /my.host/src/domains/scripts/entities/file-entities.ent
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Jul 22 18:01:25 2019 UTC