php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #70141 Gnupg cannot be installed in OpenBSD 5.7
Submitted: 2015-07-26 17:36 UTC Modified: 2015-09-09 11:39 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: emhfrbiofekg at dropmail dot me Assigned:
Status: Duplicate Package: gnupg (PECL)
PHP Version: 5.5.27 OS: OpenBSD 5.7 i386
Private report: No CVE-ID: None
 [2015-07-26 17:36 UTC] emhfrbiofekg at dropmail dot me
Description:
------------
# ./configure
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for a sed that does not truncate output... /usr/bin/sed
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... yes
checking build system type... i386-unknown-openbsd5.7
checking host system type... i386-unknown-openbsd5.7
checking target system type... i386-unknown-openbsd5.7
checking for PHP prefix... /var/www/pear
checking for PHP includes... -I/usr/local/share/php-5.5/include -I/usr/local/share/php-5.5/include/main -I/usr/local/share/php-5.5/include/TSRM -I/usr/local/share/php-5.5/include/Zend -I/usr/local/share/php-5.5/include/ext -I/usr/local/share/php-5.5/include/ext/date/lib
checking for PHP extension directory... /usr/local/lib/php-5.5/modules
checking for PHP installed headers prefix... /usr/local/share/php-5.5/include
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... re2c
checking for re2c version... 0.13.6 (ok)
checking for gawk... no
checking for nawk... no
checking for awk... awk
checking if awk is broken... no
checking for gnupg support... yes, shared
checking for gnupg files in default path... found in /usr/local/include
checking for gpgme_check_version in -lgpgme... no
configure: error: wrong gpgme lib version or lib not found

# find / -name "*gpgme*"
/usr/local/bin/gpgme-config
/usr/local/include/gpgme.h
/usr/local/info/gpgme.info-1
/usr/local/info/gpgme.info-2
/usr/local/info/gpgme.info
/usr/local/lib/libgpgme-pthread.la
/usr/local/lib/libgpgme.a
/usr/local/lib/libgpgme.la
/usr/local/lib/libgpgme.so.19.0
/usr/local/lib/libgpgme-pthread.a
/usr/local/lib/libgpgme-pthread.so.19.0

# gpgme-config --libs
-L/usr/local/lib -lgpgme -lassuan -lgpg-error
#


# ldconfig -r | grep gpgme
        259:-lgpgme.19.0 => /usr/local/lib/libgpgme.so.19.0
        261:-lgpgme-pthread.19.0 => /usr/local/lib/libgpgme-pthread.so.19.0
#

Expected result:
----------------
 

Actual result:
--------------
 http://stackoverflow.com/questions/25374452/peclgnupg-cannot-be-installed-in-openbsd-5-5

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-07-26 18:13 UTC] emhfrbiofekg at dropmail dot me
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by configure, which was
generated by GNU Autoconf 2.69.  Invocation command line was

  $ ./configure 

## --------- ##
## Platform. ##
## --------- ##

hostname = foo.my.domain
uname -m = i386
uname -r = 5.7
uname -s = OpenBSD
uname -v = GENERIC.MP#767

/usr/bin/uname -p = i386
/bin/uname -X     = unknown

/bin/arch              = unknown
/usr/bin/arch -k       = OpenBSD.i386
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo      = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /sbin
PATH: /usr/sbin
PATH: /bin
PATH: /usr/bin
PATH: /usr/X11R6/bin
PATH: /usr/local/sbin
PATH: /usr/local/bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:2297: checking for grep that handles long lines and -e
configure:2355: result: /usr/bin/grep
configure:2360: checking for egrep
configure:2422: result: /usr/bin/grep -E
configure:2427: checking for a sed that does not truncate output
configure:2481: result: /usr/bin/sed
configure:2613: checking for cc
configure:2629: found /usr/bin/cc
configure:2640: result: cc
configure:2671: checking for C compiler version
configure:2680: cc --version >&5
cc (GCC) 4.2.1 20070719 
Copyright (C) 2007 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:2691: $? = 0
configure:2680: cc -v >&5
Reading specs from /usr/lib/gcc-lib/i386-unknown-openbsd5.7/4.2.1/specs
Target: i386-unknown-openbsd5.7
Configured with: OpenBSD/i386 system compiler
Thread model: posix
gcc version 4.2.1 20070719 
configure:2691: $? = 0
configure:2680: cc -V >&5
cc: '-V' option must have argument
configure:2691: $? = 1
configure:2680: cc -qversion >&5
cc: unrecognized option '-qversion'
cc: no input files
configure:2691: $? = 1
configure:2711: checking whether the C compiler works
configure:2733: cc    conftest.c  >&5
configure:2737: $? = 0
configure:2785: result: yes
configure:2788: checking for C compiler default output file name
configure:2790: result: a.out
configure:2796: checking for suffix of executables
configure:2803: cc -o conftest    conftest.c  >&5
configure:2807: $? = 0
configure:2829: result: 
configure:2851: checking whether we are cross compiling
configure:2859: cc -o conftest    conftest.c  >&5
configure:2863: $? = 0
configure:2870: ./conftest
configure:2874: $? = 0
configure:2889: result: no
configure:2894: checking for suffix of object files
configure:2916: cc -c   conftest.c >&5
configure:2920: $? = 0
configure:2941: result: o
configure:2945: checking whether we are using the GNU C compiler
configure:2964: cc -c   conftest.c >&5
configure:2964: $? = 0
configure:2973: result: yes
configure:2982: checking whether cc accepts -g
configure:3002: cc -c -g  conftest.c >&5
configure:3002: $? = 0
configure:3043: result: yes
configure:3060: checking for cc option to accept ISO C89
configure:3123: cc  -c -g -O2  conftest.c >&5
configure:3123: $? = 0
configure:3136: result: none needed
configure:3162: checking how to run the C preprocessor
configure:3193: cc -E  conftest.c
configure:3193: $? = 0
configure:3207: cc -E  conftest.c
conftest.c:9:28: error: ac_nonexistent.h: No such file or directory
configure:3207: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE_URL ""
| /* end confdefs.h.  */
| #include <ac_nonexistent.h>
configure:3232: result: cc -E
configure:3252: cc -E  conftest.c
configure:3252: $? = 0
configure:3266: cc -E  conftest.c
conftest.c:9:28: error: ac_nonexistent.h: No such file or directory
configure:3266: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE_URL ""
| /* end confdefs.h.  */
| #include <ac_nonexistent.h>
configure:3297: checking for icc
configure:3306: result: no
configure:3320: checking for suncc
configure:3329: result: no
configure:3347: checking whether cc understands -c and -o together
configure:3375: cc -c conftest.c -o conftest2.o >&5
configure:3379: $? = 0
configure:3385: cc -c conftest.c -o conftest2.o >&5
configure:3389: $? = 0
configure:3444: result: yes
configure:3458: checking for system library directory
configure:3473: result: lib
configure:3480: checking if compiler supports -R
configure:3499: cc -o conftest -g -O2   conftest.c -R /usr/lib  >&5
configure:3499: $? = 0
configure:3509: result: yes
configure:3588: checking build system type
configure:3602: result: i386-unknown-openbsd5.7
configure:3622: checking host system type
configure:3635: result: i386-unknown-openbsd5.7
configure:3655: checking target system type
configure:3668: result: i386-unknown-openbsd5.7
configure:3771: checking for PHP prefix
configure:3773: result: /var/www/pear
configure:3775: checking for PHP includes
configure:3777: result: -I/usr/local/share/php-5.5/include -I/usr/local/share/php-5.5/include/main -I/usr/local/share/php-5.5/include/TSRM -I/usr/local/share/php-5.5/include/Zend -I/usr/local/share/php-5.5/include/ext -I/usr/local/share/php-5.5/include/ext/date/lib
configure:3779: checking for PHP extension directory
configure:3781: result: /usr/local/lib/php-5.5/modules
configure:3783: checking for PHP installed headers prefix
configure:3785: result: /usr/local/share/php-5.5/include
configure:3788: checking if debug is enabled
configure:3814: result: no
configure:3817: checking if zts is enabled
configure:3843: result: no
configure:3914: checking for re2c
configure:3930: found /usr/local/bin/re2c
configure:3941: result: re2c
configure:3950: checking for re2c version
configure:3964: result: 0.13.6 (ok)
configure:3983: checking for gawk
configure:4014: result: no
configure:3983: checking for nawk
configure:4014: result: no
configure:3983: checking for awk
configure:4000: found /usr/bin/awk
configure:4011: result: awk
configure:4034: checking if awk is broken
configure:4041: result: no
configure:4055: checking for gnupg support
configure:4095: result: yes, shared
configure:4107: checking for gnupg files in default path
configure:4112: result: found in /usr/local/include
configure:4257: checking for gpgme_check_version in -lgpgme
configure:4282: cc -o conftest -g -O2  -R/usr/local/include/lib -L/usr/local/include/lib  -lm -ldl conftest.c -lgpgme   >&5
/usr/bin/ld: cannot find -ldl
collect2: ld returned 1 exit status
configure:4282: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE_URL ""
| /* end confdefs.h.  */
| 
| /* Override any GCC internal prototype to avoid an error.
|    Use char because int might match the return type of a GCC
|    builtin and then its argument prototype would still apply.  */
| #ifdef __cplusplus
| extern "C"
| #endif
| char gpgme_check_version ();
| int
| main ()
| {
| return gpgme_check_version ();
|   ;
|   return 0;
| }
configure:4292: result: no
configure:4407: error: wrong gpgme lib version or lib not found

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=i386-unknown-openbsd5.7
ac_cv_c_compiler_gnu=yes
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_host=i386-unknown-openbsd5.7
ac_cv_lib_gpgme___gpgme_check_version=no
ac_cv_objext=o
ac_cv_path_EGREP='/usr/bin/grep -E'
ac_cv_path_GREP=/usr/bin/grep
ac_cv_prog_AWK=awk
ac_cv_prog_CPP='cc -E'
ac_cv_prog_RE2C=re2c
ac_cv_prog_ac_ct_CC=cc
ac_cv_prog_cc_c89=
ac_cv_prog_cc_cc_c_o=yes
ac_cv_prog_cc_g=yes
ac_cv_target=i386-unknown-openbsd5.7
lt_cv_path_SED=/usr/bin/sed
php_cv_cc_dashr=yes
php_cv_re2c_version='0.13.6 (ok)'

## ----------------- ##
## Output variables. ##
## ----------------- ##

AR=''
AWK='awk'
CC='cc'
CFLAGS='-g -O2'
CONFIGURE_COMMAND=' '\''./configure'\'' '
CONFIGURE_OPTIONS=''
CPP='cc -E'
CPPFLAGS=''
DEFS=''
DSYMUTIL=''
ECHO='/bin/echo'
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP='/usr/bin/grep -E'
EXEEXT=''
GNUPG_PATH=''
GREP='/usr/bin/grep'
LDFLAGS=''
LIBOBJS=''
LIBS=''
LIBTOOL=''
LN_S=''
LTLIBOBJS=''
NMEDIT=''
OBJEXT='o'
PACKAGE_BUGREPORT=''
PACKAGE_NAME=''
PACKAGE_STRING=''
PACKAGE_TARNAME=''
PACKAGE_URL=''
PACKAGE_VERSION=''
PATH_SEPARATOR=':'
RANLIB=''
RE2C='re2c'
SED='/usr/bin/sed'
SHELL='/bin/sh'
SHLIB_DL_SUFFIX_NAME='so'
SHLIB_SUFFIX_NAME='so'
STRIP=''
ac_ct_CC='cc'
bindir='${exec_prefix}/bin'
build='i386-unknown-openbsd5.7'
build_alias=''
build_cpu='i386'
build_os='openbsd5.7'
build_vendor='unknown'
datadir='${datarootdir}'
datarootdir='${prefix}/share'
docdir='${datarootdir}/doc/${PACKAGE}'
dvidir='${docdir}'
exec_prefix='NONE'
host='i386-unknown-openbsd5.7'
host_alias='i386-unknown-openbsd5.7'
host_cpu='i386'
host_os='openbsd5.7'
host_vendor='unknown'
htmldir='${docdir}'
includedir='${prefix}/include'
infodir='${datarootdir}/info'
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localedir='${datarootdir}/locale'
localstatedir='${prefix}/var'
mandir='${datarootdir}/man'
oldincludedir='/usr/include'
pdfdir='${docdir}'
prefix='/var/www/pear'
program_transform_name='s,x,x,'
psdir='${docdir}'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='${prefix}/etc'
target='i386-unknown-openbsd5.7'
target_alias=''
target_cpu='i386'
target_os='openbsd5.7'
target_vendor='unknown'

## ----------- ##
## confdefs.h. ##
## ----------- ##

/* confdefs.h */
#define PACKAGE_NAME ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""
#define PACKAGE_STRING ""
#define PACKAGE_BUGREPORT ""
#define PACKAGE_URL ""

configure: exit 1
 [2015-09-09 11:39 UTC] jimjag@php.net
-Status: Open +Status: Duplicate
 [2015-09-09 11:39 UTC] jimjag@php.net
69785
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Oct 19 14:01:28 2019 UTC