php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #69794 Behavior when calling 'runkit_function_redefine' is ill advised
Submitted: 2015-06-10 17:48 UTC Modified: 2016-08-03 22:41 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: dsandell at bio5 dot org Assigned:
Status: Not a bug Package: runkit (PECL)
PHP Version: Irrelevant OS: Cent OS
Private report: No CVE-ID: None
 [2015-06-10 17:48 UTC] dsandell at bio5 dot org
Description:
------------
When redefining built-ins without having runkit.internal_override set to 1, it would make more sense for some sort of exception or halting behavior to trigger than for it to fail silently.

Mainly I think this is problem because a) the application user/host/maintainer may never know that there's an illegal override in their code without some sort of program halting must-be-handled event triggering, and b) if an attempt at an illegal override is made, but fails, there's a good chance that everything occurring after may be unexpected behavior.

I'd actually be happy to look at the code and change this behavior, but it's not clear at all what code base is the actual maintained code base runkit and where to make a pull request (is on of the runkits on Github the real runkit?).


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-06-10 18:33 UTC] cmb@php.net
| it's not clear at all what code base is the actual maintained
| code base runkit

The sources of the PECL package are available on
<http://git.php.net/?p=pecl/php/runkit.git;a=summary>.
 [2015-09-29 09:47 UTC] dzenovich@php.net
If it is related to https://github.com/zenovich/runkit, then report the bug there, please.
 [2016-08-03 19:47 UTC] cmb@php.net
Indeed, the official runkit sources are now on
<https://github.com/zenovich/runkit>, and also the primary bug
tracker.
 [2016-08-03 22:41 UTC] pollita@php.net
-Status: Open +Status: Not a bug
 [2016-08-03 22:41 UTC] pollita@php.net
As dzenovich said, please reopen this bug on github.com/zenovich/runkit as that's not the proper home for runkit.

I'm not sure where the lack of clarity on which codebase is the maintained one lies since literally all the old repos point directly at github.com/zenovich/runkit.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Apr 19 23:01:25 2019 UTC