php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6976 ibase_query can't execute SQL statements that can't be prepared
Submitted: 2000-10-02 13:45 UTC Modified: 2003-08-10 11:41 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: mlemos at acm dot org Assigned: abies (profile)
Status: Closed Package: InterBase related
PHP Version: 4.0.2 OS: Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mlemos at acm dot org
New email:
PHP Version: OS:

 

 [2000-10-02 13:45 UTC] mlemos at acm dot org
ibase_query executes queries by preparing them first even when there are no
arguments to bind.  This prevents certain SQL statements to be executed
using PHP Interbase API to execute certain types of queries that can't be
prepared.

Interbase C API has functions that can be used to execute direct queries,
so PHP Interbase API ought to use such functions for executing direct
queries.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-10-06 07:13 UTC] jah@php.net
Unfortunately, a known fact... Will be fixed some day when both time and
brains permits. But remember that I'm not promising a fast fix for this one. :(
 [2002-05-25 09:17 UTC] derick@php.net
Any news on this Jouni?
 [2003-04-28 11:40 UTC] wez@php.net
Looks like it will never get fixed.
 [2003-08-09 22:23 UTC] abies@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip


 [2003-08-10 11:41 UTC] abies@php.net
According to the IB6 API Guide, the statements that cannot be prepared are CREATE DATABASE and SET TRANSACTION. Both of these are taken care of in the latest CVS version of PHP5.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Jan 28 21:03:34 2022 UTC