php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69328 Compilation fails on x32
Submitted: 2015-03-29 19:07 UTC Modified: 2017-10-24 14:07 UTC
From: witekfl at gazeta dot pl Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 5.4.39 OS: Linux x32
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: witekfl at gazeta dot pl
New email:
PHP Version: OS:

 

 [2015-03-29 19:07 UTC] witekfl at gazeta dot pl
Description:
------------
Compilation of php-5.4.39 fails on Linux with x32 ABI.


Expected result:
----------------
No errors.

Actual result:
--------------
./configure && make
...
Generating phar.php
Generating phar.phar
Unknown command 'pack', check ext/phar/phar.php help
Makefile:321: recipe for target 'ext/phar/phar.phar' failed


Patches

zend_operators_asm_backported_from_5.5_to_compile_on_x32 (last revision 2015-06-01 19:23 UTC) by witekfl at gazeta dot pl)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-04-15 19:21 UTC] witekfl at gazeta dot pl
-Package: PHAR related +Package: *General Issues
 [2015-04-15 19:21 UTC] witekfl at gazeta dot pl
It is a problem with arithmetic.
add.php:
<?php
$l = 2 + 2;
echo "l=$l\n";
?>

./sapi/cli/php add.php
Segmentation fault

I tried that on PLD. On Debian is likely the same result.
 [2015-04-15 21:24 UTC] cmb@php.net
-Package: *General Issues +Package: Compile Failure
 [2015-06-01 19:27 UTC] witekfl at gazeta dot pl
When zend_operators.h and zend_operators.c were copied from php-5.5.25, compile was successful. In the patch only asm changes were included. It compiles.
Is it right?
 [2017-10-24 14:07 UTC] yunosh@php.net
-Status: Open +Status: Not a bug
 [2017-10-24 14:07 UTC] yunosh@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC