php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #69040 funny opcache debug output
Submitted: 2015-02-12 11:47 UTC Modified: 2017-12-17 21:56 UTC
Votes:2
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: php at bof dot de Assigned:
Status: Duplicate Package: opcache
PHP Version: master-Git-2015-02-12 (Git) OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: php at bof dot de
New email:
PHP Version: OS:

 

 [2015-02-12 11:47 UTC] php at bof dot de
Description:
------------
Master built some minutes ago, minimalistic test script foo.php as below, running this command:

php -d opcache.enable_cli=1 foo.php

shows weird output on the "message cached script" line. What looks like an empty string in the shown "actual result" below, is really a single byte with value 1 between the two quotes.

Test script:
---------------
<?php echo "hi\n"; ?>

Expected result:
----------------
Thu Feb 12 12:43:05 2015 (25613): Message Cached script 'foo.php'
Thu Feb 12 12:43:05 2015 (25613): Message Added key '/usr/src/phb/build/master:foo.php:A'
hi

Actual result:
--------------
Thu Feb 12 12:43:05 2015 (25613): Message Cached script ''
Thu Feb 12 12:43:05 2015 (25613): Message Added key '/usr/src/phb/build/master:foo.php:A'
hi


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-12-17 21:56 UTC] nikic@php.net
-Status: Open +Status: Duplicate
 [2017-12-17 21:56 UTC] nikic@php.net
Same issue as bug #73546, which has been fixed in the meantime.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Oct 25 17:01:24 2020 UTC