php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6863 $QUERY_STRING doesn't always evaluate
Submitted: 2000-09-23 12:12 UTC Modified: 2001-04-28 16:32 UTC
From: steve at srtware dot com Assigned:
Status: Closed Package: PWS related
PHP Version: 4.0.2 OS: Windows 98 SE
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: steve at srtware dot com
New email:
PHP Version: OS:

 

 [2000-09-23 12:12 UTC] steve at srtware dot com
This is a followup to Bug id #5747...I can't edit it anymore, I assume because it's "closed."  Somehow I think I goofed...this problem *does* still exist in 4.0.2.  To reproduce (in PWS 4.0):

http://localhost/index.php?test
$QUERY_STRING == 'test'

http://localhost/?test
$QUERY_STRING == ''

In UNIX under PHP 3.0.16 both evaluate the same way (as 'test').

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-12-18 11:37 UTC] sniper@php.net
Does this happen with PHP 4.0.3pl1?

--Jani
 [2000-12-21 05:36 UTC] sniper@php.net
This works for me in Linux/Apache. So this might be
only PWS/Windows problem.

If you have somehow changed your php.ini could you
please add it into this report?

Following url will take you to correct page
where your password should work:

http://bugs.php.net/bugs.php?id=6863&edit=2


--Jani

 [2000-12-21 22:41 UTC] steve at srtware dot com
Changes to PHP.INI:

asp_tags     =       On
memory_limit = 8388608
(this setting is "8M" in the newer php.ini-dist, but I never
changed it to the one that I have...must have been an old default)
(at this point my old DOS compare util crapped out, so I will try to remember the rest...)

include_path	="\."
upload_tmp_dir	="C:\Download"
upload_max_filesize	=2097152
sendmail_from	=webmaster@srtware.com
session.save_path = \windows\temp

I think that's it.
 [2001-04-28 16:32 UTC] jmoore@php.net
this is a MSFT problem with them being non CGI complaint. Not much PHP can do about it.

- James
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu May 06 22:02:20 2021 UTC