php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #68106 Typo in ArrayIterator::setFlags
Submitted: 2014-09-26 09:43 UTC Modified: 2018-08-18 12:04 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: log dot kot at gmail dot com Assigned: salathe (profile)
Status: Closed Package: SPL related
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: log dot kot at gmail dot com
New email:
PHP Version: OS:

 

 [2014-09-26 09:43 UTC] log dot kot at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/arrayiterator.setflags
---
Documentation says that flags must be bitmask of 0 and 1.
But real values are:
1 = ArrayObject::STD_PROP_LIST
2 = ArrayObject::ARRAY_AS_PROPS

See http://php.net/manual/en/arrayobject.setflags.php


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-11-22 19:18 UTC] salathe@php.net
-Assigned To: +Assigned To: salathe
 [2015-09-08 20:31 UTC] cmb@php.net
> Documentation says that flags must be bitmask of 0 and 1.

Where does it say so? The English manual lists the constants with
their values (1 and 2) from the beginning. Is this perhaps a
translation issue?
 [2015-09-09 12:25 UTC] salathe@php.net
> The English manual lists the constants with their values (1 and 2) from the beginning.

Not for ArrayIterator, however ArrayObject does correctly describe them.
 [2017-01-28 12:46 UTC] cmb@php.net
-Package: Documentation problem +Package: SPL related
 [2018-08-18 12:03 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&revision=345528
Log: Fix #68106: Typo in ArrayIterator::setFlags
 [2018-08-18 12:04 UTC] cmb@php.net
-Status: Assigned +Status: Closed
 [2018-08-18 12:04 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Tue Oct 16 08:01:25 2018 UTC