php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #67058 substr_compare function bug
Submitted: 2014-04-11 10:13 UTC Modified: 2014-04-11 16:51 UTC
From: ferenczi dot krisztian at gmail dot com Assigned:
Status: Duplicate Package: Strings related
PHP Version: 5.5.11 OS: Debian
Private report: No CVE-ID: None
 [2014-04-11 10:13 UTC] ferenczi dot krisztian at gmail dot com
Description:
------------
The test script output on Debian: `0` instead of `1`
The script works fine on Win7 PHP 5.5.7

Test script:
---------------
<?php
echo substr_compare("test.com", ".local", -strlen(".local"));



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-04-11 10:14 UTC] ferenczi dot krisztian at gmail dot com
-Package: Unknown/Other Function +Package: Strings related
 [2014-04-11 10:14 UTC] ferenczi dot krisztian at gmail dot com
Change package
 [2014-04-11 16:51 UTC] aharvey@php.net
-Status: Open +Status: Duplicate
 [2014-04-11 16:51 UTC] aharvey@php.net
Duplicate of bug #67043.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Apr 19 08:01:25 2019 UTC