php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66819 apc_delete_file depends on file_update_protection
Submitted: 2014-03-04 11:15 UTC Modified: 2016-11-18 21:03 UTC
From: opitz at pluspol dot info Assigned:
Status: Wont fix Package: APC (PECL)
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
21 + 13 = ?
Subscribe to this entry?

 
 [2014-03-04 11:15 UTC] opitz at pluspol dot info
Description:
------------
If the configuration apc.file_update_protection is set (default 2 seconds) you can't use the function apc_delete_file after you updated a file.

The problem is, that the internal function apc_cache_make_file_key checks for configuration apc.file_update_protection. So the functionality of this internal function depends on an unnecessary configuration option.

Expected result:
----------------
Delete cache entry for file, which was generated shortly before.

Actual result:
--------------
Cache not cleared and a warning ommited: "PHP Warning: apc_delete_file(): Could not stat file ..." which is false.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-11-18 21:03 UTC] kalle@php.net
-Status: Open +Status: Wont fix
 [2016-11-18 21:03 UTC] kalle@php.net
APC is no longer supported in favor of opcache that comes bundled with PHP, if you wish to use the user cache, then look at PECL/APCu.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Sep 19 08:03:37 2021 UTC