php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #66782 [KRB5] Patch to compile krb5 module --with-krb5kadm
Submitted: 2014-02-26 18:13 UTC Modified: 2021-08-26 11:47 UTC
Votes:2
Avg. Score:3.5 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: simnet at vsfs dot org Assigned: cmb (profile)
Status: Closed Package: PECL (PECL)
PHP Version: 5.5.9 OS: Ubuntu Linux 12.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: simnet at vsfs dot org
New email:
PHP Version: OS:

 

 [2014-02-26 18:13 UTC] simnet at vsfs dot org
Description:
------------
The root problem is both MIT Kerberos and Zend define a constant named SUCCESS in an enum when compiling --with-krb5kadm. This results in a collision when compiling.

Test script:
---------------
php_krb5_kadm.h has a broken workaround for this, but still results in following compiler error:

$ phpize
$ ./configure --with-krb5kadm
$ make
/usr/include/gssrpc/rpc_msg.h:66:2: error: redeclaration of enumerator 'SUCCESS'
/usr/include/php5/Zend/zend.h:282:3: note: previous definition of 'SUCCESS' was here

Expected result:
----------------
krb5 compiles OK.

Actual result:
--------------
krb5 doesn't compile. Using the attached file, I was able to compile and deploy the krb5 module. My only concern is whether my patch is too universal and may fail a regression test I'm not thinking of. I will test some code with this module and post to this bug if something breaks.

Patches

krb5kadm.patch (last revision 2014-02-26 18:13 UTC by simnet at vsfs dot org)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-10-24 08:56 UTC] kalle@php.net
-Summary: Patch to compile krb5 module --with-krb5kadm +Summary: [KRB5] Patch to compile krb5 module --with-krb5kadm
 [2021-08-16 15:22 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2021-08-16 15:22 UTC] cmb@php.net
The respective code has been improved[1] long ago; does that work
for you, too?

[1] <https://github.com/php/pecl-authentication-krb5/commit/53c6ca0412a334c8d0853bb6e31389f98f0815a4>
 [2021-08-25 22:25 UTC] simnet at vsfs dot org
-Status: Feedback +Status: Assigned
 [2021-08-25 22:25 UTC] simnet at vsfs dot org
Looks good in theory and from what I can recall. As you can see from the age of the ticket, it's been many years since I've needed to use this plugin. If it works for you, go ahead and close the ticket.
 [2021-08-26 11:47 UTC] cmb@php.net
-Status: Assigned +Status: Closed
 [2021-08-26 11:47 UTC] cmb@php.net
Thanks for the swift reply.  I'm closing then.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 20 12:03:37 2021 UTC