php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #65782 Fatal error: Non-static method RarEntry::extract() cannot be called statically
Submitted: 2013-09-28 15:53 UTC Modified: 2013-09-28 17:28 UTC
From: rajesh dot ponyaboina at gmail dot com Assigned:
Status: Not a bug Package: rar (PECL)
PHP Version: 5.5.4 OS: windows 7
Private report: No CVE-ID: None
 [2013-09-28 15:53 UTC] rajesh dot ponyaboina at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/rarentry.extract#refsect1-rarentry.extract-description
---


Test script:
---------------
Fatal error: Non-static method RarEntry::extract() cannot be called statically

Expected result:
----------------
extracting the rar file

Actual result:
--------------
Fatal error: Non-static method RarEntry::extract() cannot be called statically

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-09-28 17:28 UTC] cataphract@php.net
-Status: Open +Status: Not a bug
 [2013-09-28 17:28 UTC] cataphract@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed May 22 08:01:26 2019 UTC