php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6499 $upload_type[] has wrong size with empty multiple-file uploads
Submitted: 2000-09-02 04:49 UTC Modified: 2001-12-18 09:36 UTC
From: daniel dot burckhardt at sur-gmbh dot ch Assigned:
Status: Closed Package: HTTP related
PHP Version: 4.0.1pl2 OS: Win NT
Private report: No CVE-ID: None
 [2000-09-02 04:49 UTC] daniel dot burckhardt at sur-gmbh dot ch
when i'm using multiple file uploads and leave some of the fields empty,
then i get
  sizeof($upload) > sizeof($upload_type);
(i assume that the problem is that $upload_type[] is not set to an empty string ""
 for files with $upload_size[$i] == 0)

so if i a have an upload form with 2 upload entries, and i leave the first one blank,
then sizeof($upload) == 2 and sizeof($upload_type) == 1 which means that
the type for  $upload[1] is in the variable $upload_type[0]

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-20 09:11 UTC] jmoore@php.net
This is what would be expected but is not good behaviour. This happens due to the first $upload_type is set to null, when an array value is null it is removed from an array. I think in this case it needs fixing.

James
 [2001-11-27 05:37 UTC] sander@php.net
Does this problem stil occur with the latest CVS (which has IIRC a new upload-system)??? (You also might try 4.0.6 or the latest RC (http://download.php.net/~zeev/php-4.1.0RC3.tar.gz))
 [2001-12-18 07:14 UTC] sander@php.net
No feedback. Closing.
 [2001-12-18 09:36 UTC] daniel dot burckhardt at sur-gmbh dot ch
doesn't occur anymore in php 4.1.0 on Win NT
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jun 18 09:01:27 2019 UTC