php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #64980 readline example doc incorrect
Submitted: 2013-06-06 17:46 UTC Modified: 2013-06-12 19:09 UTC
From: gamerscomplete at gmail dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gamerscomplete at gmail dot com
New email:
PHP Version: OS:

 

 [2013-06-06 17:46 UTC] gamerscomplete at gmail dot com
Description:
------------
Command is listed as "readline_list_history()" when the actual command is 
"readline_read_history()" in the example text at 
http://us2.php.net/manual/en/function.readline.php

"
//dump history
print_r(readline_list_history());
"




---
From manual page: http://www.php.net/function.readline#refsect1-
function.readline-examples
---



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-06-12 19:09 UTC] aharvey@php.net
-Status: Open +Status: Not a bug
 [2013-06-12 19:09 UTC] aharvey@php.net
readline_list_history() appears to be correct — readline_read_history() loads a 
history file, which isn't what the example demonstrates.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Apr 16 01:01:24 2021 UTC