php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64917 Infinite loop when using SimpleXMLElement::attributes
Submitted: 2013-05-24 13:11 UTC Modified: 2015-09-04 14:32 UTC
From: nabice at gmail dot com Assigned: cmb (profile)
Status: Duplicate Package: SimpleXML related
PHP Version: 5.4.15 OS: Linux 3.8.0
Private report: No CVE-ID: None
 [2013-05-24 13:11 UTC] nabice at gmail dot com
Description:
------------
When I use SimpleXML to find some element's attributes, A mistake leads to 
infinite loop.

I was meaning "$child->atttibutes()", but "$childs->attributes()" by mistake, 
then some strange things happen: Infinite loop.

Is it a bug?

Test script:
---------------
<?php
$xml = simplexml_load_string('<root><parent><child id="1"/><child id="2"/></parent></root>');
$childs = $xml->parent->child;
foreach($childs as $child){
	var_dump($childs->attributes());
}
?>

Expected result:
----------------
Print:

object(SimpleXMLElement)#6 (1) {
  ["@attributes"]=>
  array(1) {
    ["id"]=>
    string(1) "1"
  }
}
object(SimpleXMLElement)#6 (1) {
  ["@attributes"]=>
  array(1) {
    ["id"]=>
    string(1) "1"
  }
}

Actual result:
--------------
Infinite loop.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-09-04 14:32 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2015-09-04 14:32 UTC] cmb@php.net
This is a duplicate of bug #55098.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon May 20 18:01:27 2019 UTC