php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #64904 php_wincache.dll is faulting and bringing down iis8 hosting
Submitted: 2013-05-22 20:34 UTC Modified: 2015-02-03 23:13 UTC
Votes:12
Avg. Score:4.8 ± 0.4
Reproduced:12 of 12 (100.0%)
Same Version:6 (50.0%)
Same OS:10 (83.3%)
From: boneill81 at gmail dot com Assigned: ericsten (profile)
Status: Closed Package: WinCache (PECL)
PHP Version: 5.4.15 OS: Windows Server 2012
Private report: No CVE-ID: None
 [2013-05-22 20:34 UTC] boneill81 at gmail dot com
Description:
------------
Hi,
Myself and my colleague are trying to debig a problem which we have with a brand new server and setup. The server is Windows 2012. PHP 5.4.14 and wincache 1.3.4.0 have been installed via Microsoft web platform installer. The system is running IIS8. For the most part its fine but for the past week intermittently on a daily basis the following error is thrown for no discernible reason.

The behavior which illustrates the error is that IIS8 refuses all requests and the IIS8 logs show many 500 errors of many differing kinds but the following dump in the event viewer seems to be always the same. I would appreciate any help you can give us on this. Thanks.
 
Faulting application name: php-cgi.exe, version: 5.4.14.0, time stamp: 0x5165bd29
Faulting module name: php_wincache.dll, version: 1.3.4.0, time stamp: 0x4fd7737e
Exception code: 0xc0000094
Fault offset: 0x0001309b
Faulting process id: 0x10c4
Faulting application start time: 0x01ce5700fc8a892e
Faulting application path: C:\Program Files (x86)\PHP\v5.4\php-cgi.exe
Faulting module path: C:\Program Files (x86)\PHP\v5.4\ext\php_wincache.dll
Report Id: 3a43011a-c2f4-11e2-93ef-00155d018004
Faulting package full name: 
Faulting package-relative application ID: 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-06-21 14:29 UTC] dh at itatwork dot net
Identical issue here - 0xc0000094 is a divide by zero error.

Faulting application name: php-cgi.exe, version: 5.4.9.0, time stamp: 0x50ad2678
Faulting module name: php_wincache.dll, version: 1.3.4.0, time stamp: 0x4fd7737e
Exception code: 0xc0000094
Fault offset: 0x0001309b
Faulting process id: 0x1138
Faulting application start time: 0x01ce6e89cecc0380
Faulting application path: C:\Program Files (x86)\PHP\v5.4\php-cgi.exe
Faulting module path: C:\Program Files (x86)\PHP\v5.4\ext\php_wincache.dll
Report Id: 4143a49e-da7d-11e2-93fe-00155d503811
Faulting package full name: 
Faulting package-relative application ID:
 [2013-07-25 21:23 UTC] ericsten@php.net
Based upon the fault offset, it looks like a fault in php_wincache!utils_getindex() when the numfiles arg is 0.

Unfortunately, the utils_getindex() function is called from all over wincache.  So, without a crash dump (or minidump) with the full callstack, there's not a whole lot I can do with this bug.

If you get a crash dump, please let me know!
    --E.
 [2014-02-20 16:28 UTC] ericsten@php.net
-Assigned To: +Assigned To: ericsten
 [2014-11-17 13:12 UTC] p dot hughes at imperial dot ac dot uk
Hi all, this was a problem we encountered on Woindows 2012 R2, and php 5.5.18.

Wincache was 1.3.5.0 and in essence we were seeing the below in some respects;

Faulting application name: php-cgi.exe, version: 5.5.18.0, time stamp: 0x543ed3aa
Faulting module name: KERNEL32.DLL, version: 6.3.9600.17056, time stamp: 0x532a2e6c
Exception code: 0xc0000005
Fault offset: 0x00019072
Faulting process id: 0x9008
Faulting application start time: 0x01d00254b6a9c4f1
Faulting application path: pathhere\php-cgi.exe
Faulting module path: C:\windows\SYSTEM32\KERNEL32.DLL
Report Id: f4623cc2-6e47-11e4-80c6-0225b5010b0b
Faulting package full name: 
Faulting package-relative application ID: 

Disabling Wincache, seems to have stopped a lot of the errors coming through. Can you advise on what you would need to look at this?

Thanks
 [2015-02-03 23:13 UTC] ericsten@php.net
-Status: Assigned +Status: Closed
 [2015-02-03 23:13 UTC] ericsten@php.net
Current version of WinCache (1.3.7.1) has numerous fixes to potential crashes, esp. in the startup code path.  Closing this very old bug.
 [2019-03-19 13:54 UTC] marthasimons9999 at gmail dot com
Faulting process id: 0x1138
Faulting application start time: https://goo.gl/nuKiGX
Faulting application path: C:\Program Files (x86)\PHP\v5.4\php-cgi.exe
Faulting module path: C:\Program Files (x86)\PHP\v5.4\ext\php_wincache.dll
Report Id: 4143a49e-da7d-11e2-93fe-00155d503811
Faulting package full name: 
Faulting package-relative application ID:
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Apr 19 12:01:25 2019 UTC