php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63763 Installer provides incorrect ICU DLL versions
Submitted: 2012-12-13 20:39 UTC Modified: 2012-12-17 20:47 UTC
From: chi-yu at web dot de Assigned: szarkos (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.3.19 OS: Windows 7, Service Pack 1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
10 - 1 = ?
Subscribe to this entry?

 
 [2012-12-13 20:39 UTC] chi-yu at web dot de
Description:
------------
I just downloaded the installer version labeled with "VC9 x86 Non Thread Safe (2012-Nov-21 22:03:42)" and tried to install the INTL extension provided with the installer.

The installer apparently provides the ICU DLLs for release 4.6 but when trying to run php.exe on the command line, an error message pops ups saying that the ICU DLLs for release 4.9 are missing.

Manually downloading the 4.9 DLLs from http://site.icu-project.org/download/49 and putting them into the PHP install directory appears to fix the problem.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-12-14 08:25 UTC] pajoye@php.net
Hi Steve,

Can you take a look at it please?
 [2012-12-14 08:25 UTC] pajoye@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: szarkos
 [2012-12-14 21:38 UTC] szarkos@php.net
Hello,

Thank you for reporting this issue.

This looks like a bug in the wix scripts.  I've fixed the issue, rebuilt the MSI packages and uploaded them here:  http://windows.php.net/downloads/snaps/ostc/build/php-5.3.19-63763/

Can you please test the updated MSIs at the URL above and let me know if they resolve your issue?

Thanks!
Steve
 [2012-12-14 21:59 UTC] chi-yu at web dot de
Yes, they do.

Both MSI packages appear to install the correct ICU DLL versions and everything seems to work as it's supposed to do.
 [2012-12-17 20:47 UTC] szarkos@php.net
-Status: Assigned +Status: Closed
 [2012-12-17 20:47 UTC] szarkos@php.net
Thanks for the confirmation!  Closing ticket.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Jul 03 09:04:06 2022 UTC