|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #63320 Facets not returning results in php, but do in solr Admin
Submitted: 2012-10-21 04:15 UTC Modified: 2014-02-13 18:54 UTC
From: Assigned:
Status: Not a bug Package: solr (PECL)
PHP Version: 5.4.8 OS: Debian 6
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
New email:
PHP Version: OS:


 [2012-10-21 04:15 UTC]
I am using a query in which 1 item is pulled back from solr. If I run the query in 
Solr Admin, then it returns fine showing 1 facet item.

If I run the query using php pecl Solr, then it returns the result but no facet 

Test script:
I can email you a link to see the results if you would like

Expected result:
I expect for facets to be returned

Actual result:
No facets come back


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2012-10-26 15:40 UTC] eric dot caron at gmail dot com
If you cannot post the code on this ticket, please email them to me.

Also, what version of Solr is the server running, and what version of the PECL extension are you running?
 [2012-10-26 16:01 UTC]
Please ignore. I used filter Query and it is working as it should. Cheers for a 
great extension!
 [2014-02-13 18:54 UTC]
-Status: Open +Status: Not a bug
 [2014-02-13 18:54 UTC]
The issue doesn't concern the extension itself.
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sun Dec 10 15:01:27 2023 UTC