php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62776 SoapClient behaves different when xdebug is installed
Submitted: 2012-08-08 08:54 UTC Modified: -
From: sven at e7o dot de Assigned:
Status: Open Package: Class/Object related
PHP Version: 5.3.15 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sven at e7o dot de
New email:
PHP Version: OS:

 

 [2012-08-08 08:54 UTC] sven at e7o dot de
Description:
------------
When creating a SOAP client on a non-existing WSDL file, there will be an fatal error when xdebug is installed. In other cases it throws an Exception.

PHP Fatal error:  SOAP-ERROR: Parsing WSDL: Couldn't load from 'abc' : failed to load external entity "abc"

vs.

class SoapFault#3 (10) {
  protected $message =>
  string(90) "SOAP-ERROR: Parsing WSDL: Couldn't load from 'abc' : failed to load external entity "abc"\n"
...

Test script:
---------------
try { $a = new SoapClient('abc'); } catch (Exception $e) { var_dump($e); }

Expected result:
----------------
Same error, independent from installed extensions (ideal case: Exception because it's catchable)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-08-14 07:35 UTC] guillaume dot bretou at gmail dot com
This problem is already known.
Please see : https://bugs.php.net/bug.php?id=34657 and http://bugs.xdebug.org/bug_view_page.php?bug_id=00000609
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Apr 22 18:01:27 2019 UTC