php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #62578 New datatypes support required
Submitted: 2012-07-16 10:48 UTC Modified: 2015-02-18 07:45 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:2 (100.0%)
From: nohezp at gmail dot com Assigned:
Status: Wont fix Package: Sybase-ct (ctlib) related
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2012-07-16 10:48 UTC] nohezp at gmail dot com
Description:
------------
sybase_ct extension does not support the new datatypes "DATE" & "TIME" and possibly many more datatypes that have been added by the vendor. Request to
get all the datatypes supported in the extension.




Test script:
---------------
<?php
    sybase_min_client_severity(11);
    sybase_min_server_severity(11);
    $dbms    = "sybase";
    $server  = "SYBASE";
    $db      = "cidb";
    $uid     = "selector";
    $pwd     = "";

    $p_dbcon= @sybase_connect($server, $uid, $pwd);
    $isok   = isset($p_dbcon) && is_resource($p_dbcon);
    printf("PHP NATIVE : %-10s : CONNECT : %s\n", $dbms, $isok ? "OK" : "NOT-OK");
    if($isok)
        {
        $q= sybase_query("create table #try (a date null, b time null)");
        $q= sybase_query("insert #try values('1Jan2011', '05:00:00')");
        $q= sybase_query("select * from #try");
        $recs= sybase_fetch_assoc($q);
        $i= 0;
        foreach($recs as $k => $v) { printf("%5d | %s\n", $i, $v); $i++; };
        };
    printf("PHP NATIVE : %-10s : DB-SEL  : %s\n", $dbms, @sybase_select_db($db) ? "OK" : "NOT-OK");
    ?>


Patches

new-datatypes-support (last revision 2014-11-06 10:39 UTC by nohez at cmie dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-02-18 07:45 UTC] krakjoe@php.net
-Status: Open +Status: Wont fix
 [2015-02-18 07:45 UTC] krakjoe@php.net
The sybase maintainer has backed away from the project, since nobody new has come forward it has been removed in version 7 of PHP.

For this reason, I'm marking the bug as won't fix, it can still be found by any maintainer that might come along and revive sybase as a PECL project.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun May 26 16:01:26 2019 UTC