php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62009 UUID needs attached diff for php 5.4
Submitted: 2012-05-11 21:07 UTC Modified: 2012-06-18 23:41 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: jsnell at e-normous dot com Assigned: felipe (profile)
Status: Closed Package: uuid (PECL)
PHP Version: 5.4.3 OS: Linux
Private report: No CVE-ID: None
 [2012-05-11 21:07 UTC] jsnell at e-normous dot com
Description:
------------
pecl uuid needs function_entry changed to zend_function_entry to work with PHP 5.4


Test script:
---------------
pecl install uuid
---
or
---
pecl bundle uuid
phpize
make


Expected result:
----------------
No compile errors

Actual result:
--------------
/tmp/pear/temp/uuid/uuid.c:32:1: error: unknown type name 'function_entry'


Patches

uuid-php-5-4.diff (last revision 2012-05-11 21:08 UTC by jsnell at e-normous dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-05-18 22:53 UTC] php-bugs-2012 at ryandesign dot com
This was fixed in the repository two years ago:

http://svn.php.net/viewvc?view=revision&revision=297236

Why hasn't there been a new release of this package since then?
 [2012-06-18 23:41 UTC] felipe@php.net
A new version has been released.
 [2012-06-18 23:41 UTC] felipe@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: felipe
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Apr 18 21:01:25 2019 UTC