php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61788 error_reporting expression sequence problem
Submitted: 2012-04-20 14:36 UTC Modified: 2012-04-21 14:31 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: wangrj at infobird dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.3.10 OS: CentOS 5.4
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: wangrj at infobird dot com
New email:
PHP Version: OS:

 

 [2012-04-20 14:36 UTC] wangrj at infobird dot com
Description:
------------
the error_reporting expression in php.ini has a very strange probelm

if you want to report all types of errors info except notice and deprecated

the following expression for error_reporting does not take effect: 

error_reporting = E_ALL & ~E-NOTICE & ~E_DEPRECATED

but the following is ok

error_reporting = E_ALL & ~E_DEPRECATED & ~E-NOTICE


Besides if any notice or deprecated error has generated and reported,  you got 
HTTP 500 error under nginx when display_error = off





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-04-20 14:51 UTC] wangrj at infobird dot com
error_reporting = E_ALL & ~E-NOTICE & ~E_DEPRECATED does not take effect means

still reporting notice and deprecated errors
 [2012-04-21 14:31 UTC] laruence@php.net
-Status: Open +Status: Not a bug
 [2012-04-21 14:31 UTC] laruence@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

~E-NOTICE => ~intval(E-NOTICE) => ~0 => -1
 [2012-04-24 14:35 UTC] anon at anon dot anon
You misspelled E_NOTICE.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 17:05:44 2022 UTC