php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #61616 the new third argument of parse_ini_file is not documented
Submitted: 2012-04-04 04:44 UTC Modified: 2012-04-04 07:12 UTC
From: laruence@php.net Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 5.4.0 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: laruence@php.net
New email:
PHP Version: OS:

 

 [2012-04-04 04:44 UTC] laruence@php.net
Description:
------------
the new arguments is:

if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "p|bl", &filename, 
&filename_len, &process_sections, &scanner_mode) == FAILURE) {
        RETURN_FALSE;
}

Test script:
---------------
none

Expected result:
----------------
nonenone

Actual result:
--------------
none

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-04-04 06:50 UTC] aharvey@php.net
-Status: Open +Status: Not a bug -Type: Bug +Type: Documentation Problem
 [2012-04-04 06:50 UTC] aharvey@php.net
Looks documented to me, per http://au2.php.net/parse_ini_file:

scanner_mode
Can either be INI_SCANNER_NORMAL (default) or INI_SCANNER_RAW. If 
INI_SCANNER_RAW is supplied, then option values will not be parsed.

Unless that's changed in PHP 5.4 (which I'm pretty sure it hasn't, since it's 
not in UPGRADING and the code looks basically the same), I don't think this is 
an issue.
 [2012-04-04 07:12 UTC] laruence@php.net
ah, sorry,  the www.php.net direct me to zh doc,, it's not there.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Apr 01 00:01:22 2020 UTC