php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61592 Broken paths and missing include paths prevents compiling
Submitted: 2012-04-01 12:26 UTC Modified: 2012-04-02 01:05 UTC
From: stolen dot data dot net at gmail dot com Assigned:
Status: Duplicate Package: Compile Failure
PHP Version: 5.4.1RC1 OS: OpenBSD (and possibly others)
Private report: No CVE-ID: None
 [2012-04-01 12:26 UTC] stolen dot data dot net at gmail dot com
Description:
------------
I reported about this one month ago for 5.4.0, but the issue seems to have gone 
by unnoticed and the problems remain in 5.4.1RC1:

./configure[21153]: cd: /usr/opt/php-5.4.1RC1/"ext/date" - No such file or 
directory
./configure[59467]: cd: /usr/opt/php-5.4.1RC1/"ext/mbstring" - No such file or 
directory
./configure[59467]: cd: /usr/opt/php-5.4.1RC1/"ext/mbstring" - No such file or 
directory
./configure[59467]: cd: /usr/opt/php-5.4.1RC1/"ext/mbstring/libmbfl" - No such 
file or directory

Workaround patch for solving the quoted path subcomponents in configure:

--- SNIP ---

--- configure.old	Sun Apr  1 15:51:01 2012
+++ configure	Sun Apr  1 15:23:43 2012
@@ -21130,7 +21130,7 @@
 
     ep_dir="`echo $ext_builddir/lib|$SED 's%/*[^/][^/]*/*$%%'`"
 
-    ep_realdir="`(cd \"$ep_dir\" && pwd)`"
+    ep_realdir="`(cd $ep_dir && pwd)`"
     ai_p="$ep_realdir/`basename \"$ext_builddir/lib\"`"
   fi
 
@@ -59317,7 +59317,7 @@
 
     ep_dir="`echo $ext_builddir/$dir|$SED 's%/*[^/][^/]*/*$%%'`"
 
-    ep_realdir="`(cd \"$ep_dir\" && pwd)`"
+    ep_realdir="`(cd $ep_dir && pwd)`"
     ai_p="$ep_realdir/`basename \"$ext_builddir/$dir\"`"
   fi

--- SNIP ---

Supply missing include paths to configure in order to prevent make from halting 
on error:

CFLAGS="-Iext/mbstring/oniguruma -Iext/mbstring/libmbfl/mbfl" CPPFLAGS="-
Iext/mbstring/oniguruma -Iext/mbstring/libmbfl/mbfl" ./configure --your-usual-
flags


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-04-02 01:05 UTC] aharvey@php.net
-Status: Open +Status: Duplicate
 [2012-04-02 01:05 UTC] aharvey@php.net
Duplicate of #61234. Please don't open new bugs for bugs that simply haven't been 
dealt with yet.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Oct 16 01:01:26 2019 UTC