php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61575 APC produces undefined symbol: zend_new_interned_string
Submitted: 2012-03-30 20:26 UTC Modified: 2012-03-30 20:55 UTC
From: phpnet at vdvo dot nl Assigned:
Status: Not a bug Package: APC (PECL)
PHP Version: 5.4.0 OS: Linux / Fedora 14
Private report: No CVE-ID: None
 [2012-03-30 20:26 UTC] phpnet at vdvo dot nl
Description:
------------
Using PHP 5.4.0 and APC 3.1.9 (install to pecl or latest svn snaps) result in the following flood of my ssh console:

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/php5/ext/apc.so' - /usr/local/php5/ext/apc.so: undefined symbol: zend_new_interned_string in Unknown on line 0

Using google, I haven't found anything. In httpd on my site, APC just works and doesn't give any trouble. I've got a lot of commandline php processes running, and with every php command/start it'll throw out this error.

If more information is needed, request!

Test script:
---------------
Just type 'php' on the command line, the error comes up.

Expected result:
----------------
Expected result: php launches without error

Actual result:
--------------
PHP throws the error described in the description.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-03-30 20:35 UTC] rasmus@php.net
-Status: Open +Status: Not a bug
 [2012-03-30 20:35 UTC] rasmus@php.net
3.1.9 does not work with 5.4. Grab the trunk version from svn instead.
 [2012-03-30 20:45 UTC] phpnet at vdvo dot nl
trunk version of php or apc? Already tried with trunk version of apc. The strange thing is, that in apache there are no errors and all apc functions are working normally. Just it seems the cli doesn't like it when using the module.
 [2012-03-30 20:47 UTC] rasmus@php.net
Trunk version of APC. Your error indicates that you are trying to load an apc.so 
compiled for PHP 5.4 into PHP 5.3. Are you sure the cli php you are running is 
actually 5.4?
 [2012-03-30 20:55 UTC] phpnet at vdvo dot nl
Blindness of what the phpinfo() said I assumed it was php 5.4.0.

After your comment I did php -v, resulting in 5.3.6. I've removed /usr/bin/php (no idea why it was there) and made a symbolic link to /usr/local/php5/bin/php

It's working now, issue can be closed. Hope other people with the same issue can find this through google :)

Thanks a lot
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed May 22 19:01:32 2019 UTC