php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61433 php hangs using fastcgi, user_ini.filename with On/Off in user.ini-file on IIS6
Submitted: 2012-03-19 10:02 UTC Modified: 2014-12-03 14:59 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: php at sanexeh dot nl Assigned:
Status: Duplicate Package: IIS related
PHP Version: 5.4.0 OS: Windows Server 2003 Standard
Private report: No CVE-ID: None
 [2012-03-19 10:02 UTC] php at sanexeh dot nl
Description:
------------
Use FastCGI 1.5 RTW (x86) for IIS (fcgiext.dll).

In php.ini:

user_ini.filename = foo.php.ini

When a folder has a foo.php.ini with the following content:


On

Ie: CRLF, On, CRLF. The php-request will hang and write "Application popup:  : " to syslog (event viewer -> System). Does not happen on IIS7/Win 2008.

Test script:
---------------
foo.php.ini:

php_flag    display_errors    Off
php_flag    log_errors    On 

test.php:

<?php
phpinfo();
?>

Expected result:
----------------
phpinfo

Actual result:
--------------
php hangs

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-12-03 12:25 UTC] ab@php.net
Actually, not sure whether it's just an issue with server 2003 - but IIS6 is at least installable with the server 2012. So this looks like an issue even for the later PHP 5.5+
 [2014-12-03 14:59 UTC] ab@php.net
-Status: Open +Status: Duplicate
 [2014-12-03 14:59 UTC] ab@php.net
Similar issue was reported in bug #55541, so marking this as dup.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat May 25 14:01:27 2019 UTC