php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61013 Php logging to a file now defaults to UTC?
Submitted: 2012-02-08 16:20 UTC Modified: 2012-02-09 00:26 UTC
From: mgoebel at emich dot edu Assigned:
Status: Duplicate Package: Date/time related
PHP Version: 5.3.10 OS: Solaris 10, and SLES 11.1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mgoebel at emich dot edu
New email:
PHP Version: OS:

 

 [2012-02-08 16:20 UTC] mgoebel at emich dot edu
Description:
------------
I have a pretty generic setup on both Solaris 10 and SLES 11.1, and both setups have "date.timezone = America/Detroit" in their php.ini files.  After I upgraded from 5.3.8 to 5.3.10 all of the log entries are now using UTC instead of the localy defined timezone.

[08-Feb-2012 09:59:38] PHP Deprecated: ...
[08-Feb-2012 09:59:38] PHP Deprecated: ...
[08-Feb-2012 15:00:15 UTC] PHP Deprecated: ... 
[08-Feb-2012 15:00:15 UTC] PHP Deprecated: ... 
[08-Feb-2012 15:00:37 UTC] PHP Warning: ...

All of webpages seem to be handing date/times correctly, just the logging seems to be having issues.


Patches

LocalTime_flag_fix_for_error_reporting (last revision 2012-02-08 21:04 UTC by carloschilazo at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-02-08 21:05 UTC] carloschilazo at gmail dot com
The issue was that the local time flag was set to 0, with attached fix the local 
time flag is now fixed and the log string now contains the local time instead of 
UTC
 [2012-02-09 00:26 UTC] aharvey@php.net
-Status: Open +Status: Duplicate
 [2012-02-09 00:26 UTC] aharvey@php.net
Duplicate of bug #60723.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Apr 12 17:01:24 2021 UTC