php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #60934 authentication problem
Submitted: 2012-01-30 14:06 UTC Modified: 2012-01-30 14:22 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: sharif dot uddin at spectrumasa dot com Assigned:
Status: Not a bug Package: svn (PECL)
PHP Version: 5.3.9 OS: centos
Private report: No CVE-ID: None
 [2012-01-30 14:06 UTC] sharif dot uddin at spectrumasa dot com
Description:
------------
---
From manual page: http://www.php.net/function.svn-commit
---


How would you catch an authentication error when it is thrown by svn_commit

if(!is_array(svn_commit('Adding new survey:'. $surveyId, array( "../public/filespool/".$dirNumber."/" .$surveyId."/" ) ) )){
		// The message
		$message = "Failed to commit filespool in ".php_uname('n')." \n Filepath to commit: ../public/filespool/".$dirNumber."/" .$surveyId."/ \n SVN User: ".$svnUser;
		
		$message = wordwrap($message, 70);
		
		// Send
		mail('s.u@s.com', 'SVN Commit Failed', $message);
		$contents = "Publishing is complete but please notify IT department of survey id that you have just publish. Survey ID: ". $surveyId;
	} else{
		$contents = "Publishing is complete";
	}


the error in error log if i provide invalid user

PHP Warning:  svn_commit(): svn error(s) occured\n170001 (Authorization failed) Commit failed (details follow):\n170001 (Authorization failed) Authentication error from server: Username not found\n in ... on line 648, referer: http://...


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-01-30 14:22 UTC] aharvey@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2012-01-30 14:22 UTC] aharvey@php.net
-Status: Open +Status: Not a bug -Package: Testing related +Package: svn
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Jul 22 12:01:25 2019 UTC