php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59832 Incorrect state on package
Submitted: 2011-06-28 13:03 UTC Modified: 2013-01-06 17:19 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: mark at carrenza dot com Assigned:
Status: Not a bug Package: PECL (PECL)
PHP Version: 5.3.6 OS: CentOS 5.6 x86_64
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mark at carrenza dot com
New email:
PHP Version: OS:

 

 [2011-06-28 13:03 UTC] mark at carrenza dot com
Description:
------------
The package state for pecl_http is incorrect and currently reports a dev state for stable i.e.

[root@localhost vagrant]# pear -d preferred_state=stable search -c pecl.php.net pecl_http
Retrieving data...0%
Matched packages, channel pecl.php.net:
=======================================
Package   Stable/(Latest)   Local
pecl_http 2.0.0dev2 (devel)       Extended HTTP Support

This URL shows the correct states/versions http://pecl.php.net/package/pecl_http/download/2.0.0dev2/




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-01-06 17:19 UTC] tyrael@php.net
I think this is a generic pear problem, not pecl or package specific:

root@chronos:~# pear -d preferred_state=stable search -c pear.php.net HTTP_OAuth
Retrieving data...0%
Matched packages, channel pear.php.net:
=======================================
Package    Stable/(Latest) Local
HTTP_OAuth 0.2.3 (alpha)         PEAR implementation of the OAuth 1.0a 
specification

so pear search seems to find packages even though that the package state doesn't 
satisfy the preferred state.
you can report this to the PEAR package if you want at 
http://pear.php.net/package/PEAR
 [2013-01-06 17:19 UTC] tyrael@php.net
-Status: Open +Status: Not a bug -Package: PECL bug system +Package: PECL
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Oct 29 22:01:23 2020 UTC