php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59768 Cannot install on Xampp
Submitted: 2011-05-16 07:28 UTC Modified: 2011-05-16 07:56 UTC
From: princeshahnwaz at hotmail dot com Assigned:
Status: Not a bug Package: rar (PECL)
PHP Version: 5.3.5 OS: Window XP
Private report: No CVE-ID: None
 [2011-05-16 07:28 UTC] princeshahnwaz at hotmail dot com
Description:
------------
After installing or modifying couple of things on my xampp 
such as adding a new extension named php_rar.dll(PHP 5.3, no 
ZTS (rev 307250), well i also tried with no ZTS) which saved 
on the c:/xampp/php/ext directory and even enabled this 
php_rar.dll extension inside php.ini by adding these 
following line extension=php_rar.dll But Still I am having 
some error while restart to Apache services each time.

Here is that following error 

"PHP Startup: rar: Unable to initialize module module 
compiled with build ID=API200990626,TS,VC9 PHP compiled with 
build ID=API20090626,TS,VC6 These options need to match""

I have checked almost everything on my xampp server...

PHP 5.3.5
PEAR 1.7.2
rar-2.0.0 which is saved inside c:/xampp/htdocs/ 

While running http://localhost/rar/example ...

Having this error... 

Fatal error: Call to undefined function rar_open() in 
C:\xampp\htdocs\rar\example.php on line 9


Please help me out of this error..

Thanks in Advance..



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-05-16 07:30 UTC] tony at daylessday dot org
rar: Unable to initialize module module compiled with build ID=API200990626,TS,VC9
PHP compiled with build ID=API20090626,TS,VC6

Apparently these options do not match.
You need BOTH rar and PHP compiled for the same VC version.
 [2011-05-16 07:34 UTC] cataphract@php.net
I would add that VC6 builds of PHP have been discontinued.
Read the notice on http://windows.php.net/ and grab a VC9 build, if possible.
 [2011-05-16 07:37 UTC] princeshahnawaz at hotmail dot com
Hello tony2001,

You need BOTH rar and PHP compiled for the same VC version?

may you please make it more clear for me to understand? 
Because I have installed the version which says that it is  
compatible for PHP 5.3.. But i really cant figure it out why 
doesnt it work at all.... :(

Thanks in advance once again for your great support
 [2011-05-16 07:56 UTC] tony at daylessday dot org
They were compiled with different versions of MS compiler - MSVC6 and MSVC9.

Here you can find PHP compiled with VC9: http://windows.php.net/download/
 [2011-05-16 08:59 UTC] princeshahnawaz at hotmail dot com
Hello once again,

I would like to inform you guys that I have also installed 
php_rar.dll on my hosting server which is a Linux based 
machine.. 
But it wouldnt work also on there....

I have simply uploaded to php_rar.dll file under the root 
folder 
/php/ext/php_rar.dll

I am not sure it will gonna to work.. Because dll is not for 
linux and i have found that this extension is just for 
Windows 
binaries (VC 9, x86):

you may please have a look on it 
www.samirayousefi.com/info.php 

www.samirayousefi.com/rar/example.php

Have a same error on hosting server..

Fatal error: Call to undefined function rar_open() in 
/home4/samirayo/public_html/rar/example.php on line 9
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jul 16 02:01:26 2019 UTC