php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59745 Cannot install on x86_64 arch
Submitted: 2011-05-03 14:04 UTC Modified: 2011-09-26 18:52 UTC
From: bernard at vanhpc dot org Assigned:
Status: Closed Package: rrd (PECL)
PHP Version: 5.3.2 OS: Scientific Linux 6.0
Private report: No CVE-ID: None
 [2011-05-03 14:04 UTC] bernard at vanhpc dot org
Description:
------------
The extension fails to build in the configure stage when trying to install on a x86_64 system.




Expected result:
----------------
I expect to be able to install rrd via pecl by running `pecl install rrd`.

Actual result:
--------------
Instead, I get the following error message:

checking for rrdtool support... yes, shared
checking for rrdtool... /usr/bin/rrdtool
checking for rrdtool header files in default path... found in /usr/include
checking for rrdtool library files in default paths... not found
configure: error: Please reinstall the rrdtool distribution
ERROR: `/var/tmp/rrd/configure' failed

But rrdtool-devel RPM is installed:

rrdtool-devel-1.3.8-6.el6.x86_64

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-05-09 05:24 UTC] koubel at seznam dot cz
What is path for your librrd library on your OS? Try to find location of of librdd.(a, so, ....)
 [2011-05-09 05:31 UTC] koubel at seznam dot cz
and config.log from phpize installation will be also helpful, I try to verify and compare what is your autoconf $libdir and your real path for librrd.
 [2011-06-17 15:35 UTC] wurststulle at gmail dot com
same problem here with ubuntu 10.04 x86_64 
wurst@server:~$ which rrdtool
/usr/bin/rrdtool
 [2011-06-20 05:09 UTC] koubel at seznam dot cz
@wurststulle: again please:
- Try to find location of librrd.a/so or any other librrd binary and write me this path.
- Attach config.log or make it public on the Internet.

I have no possibility to reproduce it, because of 64bit OS.
 [2011-08-03 04:00 UTC] oj dot dupuis at gmail dot com
Same here under RHEL 5.7 (64bits):

cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 5.7 (Tikanga)


pecl install rrd
downloading rrd-1.0.3.tgz ...
Starting to download rrd-1.0.3.tgz (19,243 bytes)
......done: 19,243 bytes
11 source files, building
running: phpize
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626
building in /var/tmp/pear-build-root/rrd-1.0.3
running: /usr/local/lib/php/temp/rrd/configure
checking for egrep... grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ANSI C... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for PHP prefix... /opt/php5
checking for PHP includes... -I/opt/php5/include/php -
I/opt/php5/include/php/main -I/opt/php5/include/php/TSRM -
I/opt/php5/include/php/Zend -I/opt/php5/include/php/ext -
I/opt/php5/include/php/ext/date/lib
checking for PHP extension directory... 
/opt/php5/lib/php/extensions/no-debug-non-zts-20090626
checking for PHP installed headers prefix... 
/opt/php5/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if 
you want to regenerate PHP parsers.
checking for gawk... gawk
checking for rrdtool support... yes, shared
checking for rrdtool... /usr/bin/rrdtool
checking for rrdtool header files in default path... found 
in /usr/include
checking for rrdtool library files in default paths... not 
found
configure: error: Please reinstall the rrdtool distribution
ERROR: `/usr/local/lib/php/temp/rrd/configure' failed



Location of libraries :
locate librrd
/usr/lib64/librrd.a
/usr/lib64/librrd.la
/usr/lib64/librrd.so
/usr/lib64/librrd.so.4
/usr/lib64/librrd.so.4.0.7
/usr/lib64/librrd_th.a
/usr/lib64/librrd_th.la
/usr/lib64/librrd_th.so
/usr/lib64/librrd_th.so.4
/usr/lib64/librrd_th.so.4.0.7
/usr/lib64/pkgconfig/librrd.pc
 [2011-08-03 04:07 UTC] oj dot dupuis at gmail dot com
solved by installing 32 bits version of rrdtool
 [2011-09-26 18:52 UTC] koubel at seznam dot cz
I made searching process for rrd lib simpler. Try to use trunk please. RC for next patch version for better testing will be available soon.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Apr 20 02:01:24 2019 UTC