php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59719 Package does not install
Submitted: 2011-04-18 10:16 UTC Modified: 2011-04-19 09:03 UTC
From: aleksey dot zholdak at gmail dot com Assigned: koubel (profile)
Status: Closed Package: rrd (PECL)
PHP Version: 5.3.5 OS: FreeBSD 7.4-STABLE
Private report: No CVE-ID: None
 [2011-04-18 10:16 UTC] aleksey dot zholdak at gmail dot com
Description:
------------
Package does not install

Reproduce code:
---------------
# pecl install rrd
downloading rrd-1.0.1.tar ...
...
checking for rrdtool... /usr/local/bin/rrdtool
checking for rrdtool header files in default path... found in /usr/local/include
checking for rrdtool library files in default paths... found in /usr/local/lib
checking for rrd_create in -lrrd... no
checking for rrd_create in -lrrd... no
configure: error: wrong rrd lib version or lib not found
ERROR: `/go-pear/rrd/configure' failed

# rrdtool -v
RRDtool 1.4.5  Copyright 1997-2010 by Tobias Oetiker <tobi@oetiker.ch> Compiled Apr 12 2011 17:29:02

# pkg_version | grep rrd
rrdtool =

>pkg_info | grep rrd
rrdtool-1.4.5       Round Robin Database Tools

Expected result:
----------------
Successful installation

Actual result:
--------------
Package does not install

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-04-19 06:42 UTC] koubel at seznam dot cz
It seems that you can't compile simple C test for presence of rrd_create function from librrd, which is obligatory for extension.

So, I need more information, try to use phpize installation and attach the config.log

# wget http://pecl.php.net/get/rrd
# tar -xzf rrd-1.0.1.tgz
# cd rrd-1.0.1
# phpize
# ./configure
# make
# make install
 [2011-04-19 07:16 UTC] aleksey dot zholdak at gmail dot com
Thank you for answer, here the "congig.log": http://depositfiles.com/files/ko65grjlo
 [2011-04-19 08:39 UTC] koubel at seznam dot cz
Thanks, I found a problem:

FreeBSD doesn't have libdl, so I remove the -ldl flag from config.m4. Expect 1.0.2 soon.

part of config.log with a failed test

configure:6699: checking for rrd_create in -lrrd
configure:6724: cc -o conftest -g  -O0  -R/usr/local/lib -L/usr/local/lib  -ldl conftest.c -lrrd   >&5
/usr/bin/ld: cannot find -ldl
configure:6724: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE_URL ""
| /* end confdefs.h.  */
| 
| /* Override any GCC internal prototype to avoid an error.
|    Use char because int might match the return type of a GCC
|    builtin and then its argument prototype would still apply.  */
| #ifdef __cplusplus
| extern "C"
| #endif
| char rrd_create ();
| int
| main ()
| {
| return rrd_create ();
|   ;
|   return 0;
| }
configure:6733: result: no
 [2011-04-19 09:03 UTC] koubel at seznam dot cz
Thank you for your bug report. This issue has been fixed
in the latest released version of the package, which you can download at
http://pecl.php.net/get/rrd


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Apr 21 06:01:26 2019 UTC