php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59320 Gmagick extension conflicts with imagick
Submitted: 2010-07-23 10:11 UTC Modified: 2010-07-26 08:22 UTC
Votes:2
Avg. Score:4.5 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (50.0%)
From: pahan at hubbitus dot info Assigned:
Status: Wont fix Package: imagick (PECL)
PHP Version: 5.3.2 OS: Linux
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2010-07-23 10:11 UTC] pahan at hubbitus dot info
Description:
------------
Description:
------------
Those extensions work independently, but if loaded both often 
segfault
happened or just decode delegate not found.

Please refer to https://bugzilla.redhat.com/show_bug.cgi?
id=559675 and http://pecl.php.net/bugs/bug.php?id=17037 for
details.

Reproduce code:
---------------
php -n -d extension=gmagick.so  -i => ok, no error
php -n -d extension=imagick.so  -i => ok, no error

php -n -d extension=gmagick.so -d extension=imagick.so -i => segfault


Expected result:
----------------
No error, phpinfo data.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-07-23 10:19 UTC] mkoppanen@php.net
Hello,

why are you opening this issue again? It has already been closed as Won't fix once.
 [2010-07-26 07:24 UTC] pahan at hubbitus dot spb dot su
I'm do not open it again, additional to gmagick extension I 
also fill it error to imagick extension too, as it also 
affected.

I wasn't known what you maintain both.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Apr 25 14:01:25 2019 UTC