php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #58891 Passing of parameters by reference should be changed.
Submitted: 2009-10-12 15:14 UTC Modified: 2015-04-04 05:28 UTC
From: marko at ultimate dot in dot rs Assigned: remi (profile)
Status: Closed Package: uuid (PECL)
PHP Version: 5.2.3 OS:
Private report: No CVE-ID: None
 [2009-10-12 15:14 UTC] marko at ultimate dot in dot rs
Description:
------------
Version: 1.6.2-0ubuntu1

This extension uses pass-by-reference which is deprecated and produces a warning in PHP >= 5.3.0.

It should be modified to accept parameters by value instead.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-03-29 07:43 UTC] anthon dot pang at gmail dot com
That's not the PECL uuid extension.

Ubuntu's php5-uuid package the OSSP uuid implementation where this problem has already been reported.  https://bugs.launchpad.net/ubuntu/+source/ossp-uuid/+bug/692968
 [2015-04-04 05:28 UTC] remi@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: remi
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jul 23 04:01:26 2019 UTC