php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58716 Solution: related to PHP Bugs: #32954 & #8715
Submitted: 2009-06-10 18:37 UTC Modified: 2017-04-01 20:40 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: amitshahc at hotmail dot com Assigned:
Status: Wont fix Package: informix (PECL)
PHP Version: 5.2.9 OS: RHEL5, any linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: amitshahc at hotmail dot com
New email:
PHP Version: OS:

 

 [2009-06-10 18:37 UTC] amitshahc at hotmail dot com
Description:
------------
Solution: related to PHP Bugs: #32954 & #8715.


I think it's memory issue with apache handling the informix result id.
with text datatype. i don't know exactly as i am not ESQL/C developer.
but i used a combination of settings before executing the select query which have the text field in the result.

Set
ifx_blobinfile_mode(1);
ifx_textasvarchar(0);

will return the blob id, in text field value instead of the giving text contect directly into that field. 

then do
ifx_get_blob($row['text_field_name']). 
will return the file name. and then read that file content, store it in the variable. and delete the file. 

doing
ifx_free_blob($row['text_field_name']);
again crashes the php script sometimes. so don't do it. 

but you can do ifx_free_result($resultId); at the end of the script.

All The Best...

sorry, this bug means not solutions but let us consider it as a trick or tip or the way to overcome the bug.
Amit Shah



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-01 20:40 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 20:40 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2009, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jan 18 00:01:23 2020 UTC