php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58413 Where is the uploaded file? Problems w/ tmp dir
Submitted: 2008-11-13 18:09 UTC Modified: 2009-01-21 10:54 UTC
From: tobias dot weber at roglink dot com Assigned:
Status: Not a bug Package: uploadprogress (PECL)
PHP Version: 5.2.5 OS: OpensuSE 11
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tobias dot weber at roglink dot com
New email:
PHP Version: OS:

 

 [2008-11-13 18:09 UTC] tobias dot weber at roglink dot com
Description:
------------
Uploading seems to work fine- 
the example updates fine, etc- but it seems like either no file is actually being uploaded or at least cannot be found anywhere on the server.
It says is uploads to /tmp - no matter what upload_tmp directory in php.ini is set.
PHP version is 5.2.6 on OpenSuSE 11, 2.6.25.5-1.1.

module was installed w/ pecl coming w/ SuSE's php-develop package: pecl install uploadprogress-beta.


No errors.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-01-06 15:53 UTC] jonny dot roller at gmail dot com
Although I'm running on a different platform, I am also getting the same problem as others have reported on this package.  I've added some "primitive" diagnostics to the uploadprogress_php_rfc1867_file() function in order to try to find out what is happening.

Although I don't totally understand the architecture, I'm guessing that this function should be getting called repeatedly as the file is being uploaded.  What I found, however, was that it is only being called at the end of the upload process.  The temporary file is being created, written to and deleted but only after the upload is complete.

I'd be more than happy to help correct this problem, but I lack the knowledge to do so on my own.  I can find my way around C and can recompile changes into my environment, however.

This is a great addition to PHP... let me know what I can do to help out.
 [2009-01-14 10:59 UTC] tobias dot weber at roglink dot com
Jonny,

u r right- it seems to try to load the tmp file into memory, since there is an enormous increase in memory consumption- although judging from what it is supposed to do it does not make any sense to load it in to memory prior to writing to disc.
is here still s.o. worlink on this package or do we have to call it
"nice approach, but we did't maintain it ..."?
Would be a pitty ...
 [2009-01-15 01:45 UTC] chregu@php.net
What webserver are you using.

Where does it say, that "it is uploads to /tmp", that path 
is certainly nowhere hardcoded

And the increase in memory consumption shouldn't happen 
either, I never experienced that.

Please provide more information, I can't debug it with this.
 [2009-01-21 05:48 UTC] chregu@php.net
Please set the php.ini directive of

uploadprogress.file.filename_template

to a directory, which exists. then it should work.

default is "/tmp/upt_%s.txt"

(the second part is the file, which it creates
 [2009-01-21 05:56 UTC] chregu@php.net
see comment above :)
 [2009-01-21 10:54 UTC] tobias dot weber at roglink dot com
Will try this weekend and check back w/ you guys.
ThanX so far.
 [2009-01-22 11:32 UTC] jonny dot roller at gmail dot com
chregu,

I had "uploadprogress.file.filename_template = 
/tmp/upt_%s.txt" in my php.ini.  I know that part is working 
because if I remove the code that erases this temporary 
file, it exists after the upload is complete.

I'm running Apache 2.2.4, PHP 5.2.2 on Red Hat Enterprise 
Linux ES release 4 (Nahant Update 6).

Let me know what else I can provide or try on my end.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jan 29 05:01:24 2020 UTC