php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58366 running via Apache - Permission Denied
Submitted: 2008-10-05 23:37 UTC Modified: 2008-10-07 23:29 UTC
From: czerwonka at arcticpenguin dot ca Assigned:
Status: Closed Package: svn (PECL)
PHP Version: 5.2.3 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: czerwonka at arcticpenguin dot ca
New email:
PHP Version: OS:

 

 [2008-10-05 23:37 UTC] czerwonka at arcticpenguin dot ca
Description:
------------
I've got a PHP script being executed by Apache (www user) :

<?php
echo 'SVN Client is ' . svn_client_version();
svn_auth_set_parameter(SVN_AUTH_PARAM_DEFAULT_USERNAME, "aczerwon");
?>

I'm getting an error on the second line (first on reports 1.4.0 correctly) saying:

svn_auth_set_parameter(): svn error(s) occured\n13 (Permission denied) Can't open file '/root/.subversion/servers': Permission denied

Alan Knowles asked me to log this bug.  

reference / and looking at svn's source code.
http://svn.haxx.se/dev/archive-2005-09/1094.shtml


According to Alan, you need to add svn_config_ensure("dir");
err = svn_config_ensure(opt_state.config_dir, pool);





Reproduce code:
---------------
Nothing special.  Simply install the svn extension and have Apache run a script and you get this error.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-10-07 19:50 UTC] scottmac@php.net
Function added but it doesn't do what you expect.

All this function does is ensure that the specified path looks like a subversion file.

I think what you want is

svn_auth_set_parameter(SVN_AUTH_PARAM_CONFIG_DIR, '/www/site/.svn');
 [2008-10-07 23:29 UTC] czerwonka at arcticpenguin dot ca
If that's the case, can we then add that function?
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Dec 06 18:03:34 2021 UTC